summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilken 'Akiko' Gottwalt2015-11-27 11:53:36 +0100
committerWilken 'Akiko' Gottwalt2015-11-27 11:53:36 +0100
commita13725ae4d5125978a2a973db16990dc5cd2489b (patch)
treeddc971fca66d53f11767fab46160b96609d526c6
downloadaur-a13725ae4d5125978a2a973db16990dc5cd2489b.tar.gz
Initial commit of OpenMAX Bellagio FBdevSink component build script including
64 bit fix.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
-rw-r--r--libomxfbdevsink_64bit.patch27
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b9b8a160ade
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libomxil-component-fbdevsink
+ pkgdesc = An opensource implementation of the OpenMAX Integration Layer API - FBdevSink component
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://omxil.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = glibc
+ source = http://downloads.sourceforge.net/project/omxil/components/libomxfbdevsink-0.1.tar.gz
+ md5sums = 6a6a452bd8c9c4fb64f7913ba0884732
+
+pkgname = libomxil-component-fbdevsink
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e06770ed0d79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id$
+# Maintainer: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+# Contributor: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+
+pkgname=libomxil-component-fbdevsink
+pkgver=0.1
+pkgrel=1
+pkgdesc="An opensource implementation of the OpenMAX Integration Layer API - FBdevSink component"
+arch=('i686' 'x86_64')
+url="http://omxil.sourceforge.net"
+license=('LGPL')
+depends=('glibc')
+source=("http://downloads.sourceforge.net/project/omxil/components/libomxfbdevsink-${pkgver}.tar.gz")
+md5sums=('6a6a452bd8c9c4fb64f7913ba0884732')
+
+prepare() {
+ cd ${srcdir}/libomxfbdevsink-${pkgver}
+
+ [ -f Makefile ] && make distclean
+ patch -Np0 -i ../../libomxfbdevsink_64bit.patch
+ autoreconf -fiv
+}
+
+build() {
+ cd ${srcdir}/libomxfbdevsink-${pkgver}
+
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd ${srcdir}/libomxfbdevsink-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/libomxfbdevsink_64bit.patch b/libomxfbdevsink_64bit.patch
new file mode 100644
index 000000000000..02174d8e7026
--- /dev/null
+++ b/libomxfbdevsink_64bit.patch
@@ -0,0 +1,27 @@
+proper memory address printf
+
+Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+
+--- src/omx_fbdev_sink_component.c.orig 2015-11-27 11:46:44.478803120 +0100
++++ src/omx_fbdev_sink_component.c 2015-11-27 11:48:59.177544525 +0100
+@@ -76,7 +76,7 @@
+ return OMX_ErrorInsufficientResources;
+ }
+ } else {
+- DEBUG(DEB_LEV_FUNCTION_NAME, "In %s, Error Component %x Already Allocated\n", __func__, (int)openmaxStandComp->pComponentPrivate);
++ DEBUG(DEB_LEV_FUNCTION_NAME, "In %s, Error Component %p Already Allocated\n", __func__, openmaxStandComp->pComponentPrivate);
+ }
+
+ omx_fbdev_sink_component_Private = openmaxStandComp->pComponentPrivate;
+@@ -265,7 +265,10 @@
+ return OMX_ErrorHardware;
+ }
+
+- DEBUG(DEB_LEV_SIMPLE_SEQ, "mmap framebuffer memory =%x omx_fbdev_sink_component_Private->product=%d stride=%d\n",(int)omx_fbdev_sink_component_Private->scr_ptr,(int)omx_fbdev_sink_component_Private->product,(int)omx_fbdev_sink_component_Private->fbstride);
++ DEBUG(DEB_LEV_SIMPLE_SEQ, "mmap framebuffer memory =%p omx_fbdev_sink_component_Private->product=%d stride=%d\n",
++ omx_fbdev_sink_component_Private->scr_ptr,
++ (int)omx_fbdev_sink_component_Private->product,
++ (int)omx_fbdev_sink_component_Private->fbstride);
+ DEBUG(DEB_LEV_SIMPLE_SEQ, "Successfully opened %s for display.\n", "/dev/fb0");
+ DEBUG(DEB_LEV_SIMPLE_SEQ, "Display Size: %u x %u\n", (int)omx_fbdev_sink_component_Private->fbwidth, (int)omx_fbdev_sink_component_Private->fbheight);
+ DEBUG(DEB_LEV_SIMPLE_SEQ, "Bitdepth: %u\n", (int)omx_fbdev_sink_component_Private->fbbpp);