summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilken 'Akiko' Gottwalt2015-11-27 11:40:23 +0100
committerWilken 'Akiko' Gottwalt2015-11-27 11:40:23 +0100
commita20e86db24e73df08a3248565b88d4159d7ed430 (patch)
treef8287215ca4efa2fa94dc2587275c862537f5c3e
downloadaur-libomxil-component-mad.tar.gz
Initial commit of OpenMAX Bellagio MAD component build script including
64 bit fix.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
-rw-r--r--libomxmad_64bit.patch17
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dba5566db561
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libomxil-component-mad
+ pkgdesc = An opensource implementation of the OpenMAX Integration Layer API - MAD component
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://omxil.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = glibc
+ source = http://downloads.sourceforge.net/project/omxil/components/libomxmad-0.1.tar.gz
+ md5sums = b2e398ef611b628ffc7c38a0accff2a6
+
+pkgname = libomxil-component-mad
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9f69d1f0ca9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id$
+# Maintainer: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+# Contributor: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+
+pkgname=libomxil-component-mad
+pkgver=0.1
+pkgrel=1
+pkgdesc="An opensource implementation of the OpenMAX Integration Layer API - MAD component"
+arch=('i686' 'x86_64')
+url="http://omxil.sourceforge.net"
+license=('LGPL')
+depends=('glibc')
+source=("http://downloads.sourceforge.net/project/omxil/components/libomxmad-${pkgver}.tar.gz")
+md5sums=('b2e398ef611b628ffc7c38a0accff2a6')
+
+prepare() {
+ cd ${srcdir}/libomxmad-${pkgver}
+
+ [ -f Makefile ] && make distclean
+ patch -Np0 -i ../../libomxmad_64bit.patch
+ autoreconf -fiv
+}
+
+build() {
+ cd ${srcdir}/libomxmad-${pkgver}
+
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd ${srcdir}/libomxmad-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/libomxmad_64bit.patch b/libomxmad_64bit.patch
new file mode 100644
index 000000000000..0dd5c7e1ad6b
--- /dev/null
+++ b/libomxmad_64bit.patch
@@ -0,0 +1,17 @@
+proper memory address printf
+
+Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+
+--- src/omx_maddec_component.c.orig 2015-11-27 11:35:13.591909600 +0100
++++ src/omx_maddec_component.c 2015-11-27 11:35:32.438400973 +0100
+@@ -86,8 +86,8 @@
+ return OMX_ErrorInsufficientResources;
+ }
+ } else {
+- DEBUG(DEB_LEV_FUNCTION_NAME, "In %s, Error Component %x Already Allocated\n",
+- __func__, (int)openmaxStandComp->pComponentPrivate);
++ DEBUG(DEB_LEV_FUNCTION_NAME, "In %s, Error Component %p Already Allocated\n",
++ __func__, openmaxStandComp->pComponentPrivate);
+ }
+
+ omx_maddec_component_Private = openmaxStandComp->pComponentPrivate;