summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-06-14 16:04:48 +0200
committersL1pKn072017-06-14 16:04:48 +0200
commitc0ae60ac56cdc17f70ab14f9c61f57514c51713e (patch)
tree6fa03e89c2b78bd975162d980cf5254173502492
downloadaur-c0ae60ac56cdc17f70ab14f9c61f57514c51713e.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD44
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc684bd8064d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Jun 14 14:04:48 UTC 2017
+pkgbase = libopenblas
+ pkgdesc = An optimized BLAS library based on GotoBLAS2 1.13 BSD
+ pkgver = 0.2.19
+ pkgrel = 1
+ url = http://www.openblas.net
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = perl
+ makedepends = gcc-fortran
+ depends = gcc-libs
+ options = !emptydirs
+ source = OpenBLAS-v0.2.19.tar.gz::http://github.com/xianyi/OpenBLAS/archive/v0.2.19.tar.gz
+ sha256sums = 9c40b5e4970f27c5f6911cb0a28aa26b6c83f17418b69f8e5a116bb983ca8557
+
+pkgname = libopenblas
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..679a24d4d20e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=libopenblas
+_pkgname=OpenBLAS
+pkgver=0.2.19
+pkgrel=1
+pkgdesc="An optimized BLAS library based on GotoBLAS2 1.13 BSD"
+arch=('i686' 'x86_64')
+url='http://www.openblas.net'
+license=('BSD')
+depends=('gcc-libs')
+makedepends=('perl'
+ 'gcc-fortran'
+ )
+options=(!emptydirs)
+source=("${_pkgname}-v${pkgver}.tar.gz::http://github.com/xianyi/OpenBLAS/archive/v${pkgver}.tar.gz")
+sha256sums=('9c40b5e4970f27c5f6911cb0a28aa26b6c83f17418b69f8e5a116bb983ca8557')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ make \
+ USE_OPENMP=1 \
+ NO_AFFINITY=1 \
+ MAJOR_VERSION=3 \
+ NUM_THREADS="$(nproc)"
+
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ make \
+ PREFIX="${pkgdir}/usr" \
+ NUM_THREADS=$(nproc) \
+ OPENBLAS_INCLUDE_DIR="${pkgdir}/usr/include/openblas" \
+ MAJOR_VERSION=3 \
+ install
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+
+ sed -i -e "s%${pkgdir}%%" "${pkgdir}/usr/lib/cmake/openblas/OpenBLASConfig.cmake"
+}