summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-12-04 14:30:07 +0000
committerDaniel Bermond2018-12-04 16:44:21 +0000
commit0a0b940176837868496e2bfe2baa31c15032fae1 (patch)
treef6212a8c58d8ae9bfe4d0a55651fcb4352885557
parent7d9e6b9cab755a022043a60aebe2eab2b4d4199d (diff)
downloadaur-0a0b940176837868496e2bfe2baa31c15032fae1.tar.gz
Use https url. Do not rename the source clone. Dependencies update.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b94a0dc63538..1d300945ea6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = libopenshot-git
pkgdesc = A high quality, open-source video editing, animation, and playback library for C++, Python, and Ruby (git version)
- pkgver = 0.2.2.r0.gc90fb9b
- pkgrel = 2
- url = http://www.openshot.org/
+ pkgver = 0.2.2.r3.g31e9e7b
+ pkgrel = 1
+ url = https://www.openshot.org/
arch = i686
arch = x86_64
license = LGPL3
@@ -14,14 +14,14 @@ pkgbase = libopenshot-git
depends = libmagick6
depends = ffmpeg
depends = x264
- depends = libopenshot-audio
+ depends = libopenshot-audio-git
depends = python
depends = jsoncpp
depends = qt5-multimedia
depends = zeromq
provides = libopenshot
conflicts = libopenshot
- source = libopenshot-git::git+https://github.com/OpenShot/libopenshot.git
+ source = git+https://github.com/OpenShot/libopenshot.git
sha256sums = SKIP
pkgname = libopenshot-git
diff --git a/PKGBUILD b/PKGBUILD
index 93bcd583cf8f..9811adc754ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
# Maintainer: Daniel Bermond < gmail-com: danielbermond >
pkgname=libopenshot-git
-pkgver=0.2.2.r0.gc90fb9b
-pkgrel=2
+_srcname=libopenshot
+pkgver=0.2.2.r3.g31e9e7b
+pkgrel=1
pkgdesc='A high quality, open-source video editing, animation, and playback library for C++, Python, and Ruby (git version)'
arch=('i686' 'x86_64')
-url='http://www.openshot.org/'
+url='https://www.openshot.org/'
license=('LGPL3')
-depends=('libmagick6' 'ffmpeg' 'x264' 'libopenshot-audio' 'python' 'jsoncpp' 'qt5-multimedia' 'zeromq')
+depends=('libmagick6' 'ffmpeg' 'x264' 'libopenshot-audio-git' 'python' 'jsoncpp' 'qt5-multimedia' 'zeromq')
makedepends=('git' 'cmake' 'doxygen' 'swig' 'unittestpp')
provides=('libopenshot')
conflicts=('libopenshot')
-source=("$pkgname"::'git+https://github.com/OpenShot/libopenshot.git')
+source=('git+https://github.com/OpenShot/libopenshot.git')
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$_srcname"
# git, tags available
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "$pkgname"
+ cd "$_srcname"
mkdir -p build
cd build
@@ -39,7 +40,7 @@ build() {
}
package() {
- cd "${pkgname}/build"
+ cd "${_srcname}/build"
make DESTDIR="$pkgdir" install
}