summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-07-23 22:01:34 -0300
committerDaniel Bermond2017-07-23 22:01:34 -0300
commitb5f166126e4688117bce4d0129ce83c4718e8dfd (patch)
tree2ea030c10adaebb1816472678f10dba0df40d576
downloadaur-b5f166126e4688117bce4d0129ce83c4718e8dfd.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD64
2 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c2126d5b378
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Mon Jul 24 01:01:29 UTC 2017
+pkgbase = libopenshot-git
+ pkgdesc = A high quality, open-source video editing, animation, and playback library for C++, Python, and Ruby (git version)
+ pkgver = 0.1.7.r3.gc30dbb9
+ pkgrel = 1
+ url = http://www.openshot.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = doxygen
+ makedepends = swig
+ makedepends = unittestpp
+ depends = imagemagick
+ depends = ffmpeg
+ depends = libx264
+ depends = libopenshot-audio
+ depends = python
+ depends = jsoncpp
+ depends = qt5-multimedia
+ depends = zeromq
+ provides = libopenshot
+ conflicts = libopenshot
+ source = libopenshot-git::git+https://github.com/OpenShot/libopenshot.git
+ sha256sums = SKIP
+
+pkgname = libopenshot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32c24d35c468
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
+
+pkgname=libopenshot-git
+pkgver=0.1.7.r3.gc30dbb9
+pkgrel=1
+pkgdesc='A high quality, open-source video editing, animation, and playback library for C++, Python, and Ruby (git version)'
+arch=('i686' 'x86_64')
+url='http://www.openshot.org/'
+license=('LGPL3')
+depends=('imagemagick' 'ffmpeg' 'libx264' 'libopenshot-audio' 'python' 'jsoncpp' 'qt5-multimedia' 'zeromq')
+makedepends=('git' 'cmake' 'doxygen' 'swig' 'unittestpp')
+provides=('libopenshot')
+conflicts=('libopenshot')
+source=("$pkgname"::'git+https://github.com/OpenShot/libopenshot.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+
+ # git, tags available
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+build() {
+ cd "$pkgname"
+ mkdir -p build
+ cd build
+
+ if command -v magick >/dev/null 2>&1
+ then
+ local _im_command='magick'
+ else
+ local _im_command='convert'
+ fi
+
+ if "$_im_command" --version | grep -q 'HDRI'
+ then
+ local _hdri='1'
+ else
+ local _hdri='0'
+ fi
+
+ local _depth="$("$_im_command" --version | grep -oE 'Q[0-9]+' | sed 's/Q//')"
+
+ #export CXXFLAGS+=" -std=gnu++98"
+
+ cmake \
+ -DCMAKE_BUILD_TYPE:STRING='Release' \
+ -DCMAKE_COLOR_MAKEFILE:BOOL='ON' \
+ -DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -DUSE_SYSTEM_JSONCPP:BOOL='ON' \
+ -DMAGICKCORE_HDRI_ENABLE="$_hdri" \
+ -DMAGICKCORE_QUANTUM_DEPTH="$_depth" \
+ -DENABLE_RUBY='0' \
+ -Wno-dev \
+ ..
+ make
+}
+
+package() {
+ cd "$pkgname"
+ cd build
+ make DESTDIR="$pkgdir" install
+}