summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-11-22 00:28:55 +0800
committerChocobo12017-11-22 00:31:15 +0800
commit70c9f22b0c46e3b2eae576c9efac8f90805ea126 (patch)
tree39226fc0e7857c76dbeb3a9c4b4bd26350f20d94
downloadaur-70c9f22b0c46e3b2eae576c9efac8f90805ea126.tar.gz
newpkg: libopusenc 0.1.1-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..efca43da81c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libopusenc
+ pkgdesc = High-level API for encoding .opus files
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://opus-codec.org/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = glibc
+ depends = opus
+ options = staticlibs
+ source = https://archive.mozilla.org/pub/opus/libopusenc-0.1.1.tar.gz
+ sha256sums = 02e6e0b14cbbe0569d948a46420f9c9a81d93bba32dc576a4007cbf96da68ef3
+
+pkgname = libopusenc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd90d3773963
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libopusenc
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="High-level API for encoding .opus files"
+arch=('i686' 'x86_64')
+url="https://opus-codec.org/"
+license=('BSD')
+depends=('glibc' 'opus')
+options=('staticlibs')
+source=("https://archive.mozilla.org/pub/opus/libopusenc-$pkgver.tar.gz")
+sha256sums=('02e6e0b14cbbe0569d948a46420f9c9a81d93bba32dc576a4007cbf96da68ef3')
+
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix="/usr"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/libopusenc/COPYING"
+ rm "$pkgdir/usr/share/doc/libopusenc/COPYING"
+}