summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgileri2016-02-14 22:30:53 +0100
committergileri2016-02-14 22:32:40 +0100
commitf546be1fbb39507d736de1be045a81c4c11b1249 (patch)
treefcfca17f3b1de7ac83ab800fde2c0edebedb583e
downloadaur-f546be1fbb39507d736de1be045a81c4c11b1249.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD41
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fc2da4f1dae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by makepkg 5.0.0
+# Sun Feb 14 21:31:49 UTC 2016
+pkgbase = libosmium-git
+ pkgdesc = Fast and flexible C++ library for working with OpenStreetMap data.
+ pkgver = v2.6.0.r3.ge723fc4
+ pkgrel = 1
+ url = http://osmcode.org/libosmium/
+ arch = x86_64
+ arch = i686
+ license = custom
+ depends = expat
+ depends = zlib
+ depends = bzip2
+ depends = boost-libs
+ optdepends = sparsehash: sparse-mem-table index map
+ optdepends = gdal: convert OSM geometries into OGR geometries
+ optdepends = geos: convert OSM geometries into GEOS geometries
+ optdepends = proj: project OSM coordinates into spatial reference systems
+ optdepends = doxygen: build Libosmium API documentation
+ conflicts = libosmium
+ source = libosmium::git+https://github.com/osmcode/libosmium.git
+ md5sums = SKIP
+
+pkgname = libosmium-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..023e32702b6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: gileri <twiked at gmail d(0)t com>
+pkgname=libosmium-git
+pkgver=v2.6.0.r3.ge723fc4
+pkgrel=1
+pkgdesc="Fast and flexible C++ library for working with OpenStreetMap data."
+url="http://osmcode.org/libosmium/"
+arch=('x86_64' 'i686')
+license=('custom')
+depends=('expat' 'zlib' 'bzip2' 'boost-libs')
+optdepends=('sparsehash: sparse-mem-table index map'
+ 'gdal: convert OSM geometries into OGR geometries'
+ 'geos: convert OSM geometries into GEOS geometries'
+ 'proj: project OSM coordinates into spatial reference systems'
+ 'doxygen: build Libosmium API documentation')
+conflicts=(libosmium)
+source=('libosmium::git+https://github.com/osmcode/libosmium.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd libosmium
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ mkdir "${srcdir}"/libosmium/build
+ cd libosmium/build
+ cmake \
+ -DINSTALL_GDALCPP=ON \
+ -DINSTALL_PROTOZERO=ON \
+ -DINSTALL_UTFCPP=ON \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ ..
+ make
+}
+
+package() {
+ cd "${srcdir}/libosmium/build"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 ../LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}