summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Johnson2022-07-03 13:59:22 -0700
committerMatt Johnson2022-07-03 14:09:40 -0700
commit41af3475a965bcdbb597f5e8fcdc70651ef4a6d1 (patch)
tree7a2741acd149068d9dadba7707c3c0fd84184596
parent3a8b84e973402361871b0bec7d571debb4f12aa1 (diff)
downloadaur-41af3475a965bcdbb597f5e8fcdc70651ef4a6d1.tar.gz
Enable systemd logging target
As recommended by one of the upstream maintainers, this commit enables systemd-journald logging to match the builds on other platforms. If upstream were to make linking the systemd library runtime configurable this could be moved to optdepends, but I think currently needs to be a full dependency if the switch is enabled at compile time.
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be52cea31095..d26e6c122580 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ url="https://osmocom.org/projects/libosmocore/"
license=('GPL')
groups=()
provides=()
-depends=('pcsclite' 'lksctp-tools' 'talloc' 'gnutls')
+depends=('pcsclite' 'lksctp-tools' 'talloc' 'gnutls' 'systemd-libs')
optdepends=('libusb: libosmousb support')
makedepends=('autoconf' 'automake' 'make' 'gcc' 'libtool' 'git' 'pkg-config' 'libusb')
@@ -23,7 +23,8 @@ build() {
autoreconf -i
./configure --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --datadir=/usr/share \
- --libexecdir=/usr/lib --localstatedir=/var --docdir=/usr/share/doc/libosmocore --libdir=/usr/lib/
+ --libexecdir=/usr/lib --localstatedir=/var --docdir=/usr/share/doc/libosmocore --libdir=/usr/lib/ \
+ --enable-systemd-logging
make
}