summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIru Cai2019-06-01 15:57:12 +0800
committerIru Cai2019-06-01 15:57:12 +0800
commitaafdc9a69d0b7577ebac1d8568fe615a508b5375 (patch)
tree4e159f0ba51d48ae3531c2c349d7e09f9fe65006
parent60a10f5a95084d9de764173dbe279ae71c3c708d (diff)
downloadaur-aafdc9a69d0b7577ebac1d8568fe615a508b5375.tar.gz
do not use -padentic-errors when building
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--nopedantic.patch15
3 files changed, 28 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 846af0b612cb..5d63fafb613f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libotr-ng-git
pkgdesc = A new implementation of OTR with support for version 4.
- pkgver = 2270.2d718c6
+ pkgver = 2783.b40e1410
pkgrel = 1
url = https://github.com/otrv4/libotr-ng
arch = i686
@@ -12,7 +12,9 @@ pkgbase = libotr-ng-git
depends = libotr
depends = libgcrypt
source = git+https://github.com/otrv4/libotr-ng.git
+ source = nopedantic.patch
sha256sums = SKIP
+ sha256sums = 5e4b09cced2c12e592caae20a9ee1723090cae9885ced69205947be4d9385b57
pkgname = libotr-ng-git
diff --git a/PKGBUILD b/PKGBUILD
index 557bbb659443..d41ebd472b61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,26 @@
pkgname='libotr-ng-git'
_pkgname='libotr-ng'
-pkgver=2270.2d718c6
+pkgver=2783.b40e1410
pkgrel=1
pkgdesc='A new implementation of OTR with support for version 4.'
arch=('i686' 'x86_64')
url='https://github.com/otrv4/libotr-ng'
license=('LGPL')
depends=('glib2' 'libgoldilocks-git' 'libsodium' 'libotr' 'libgcrypt')
-source=('git+https://github.com/otrv4/libotr-ng.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/otrv4/libotr-ng.git'
+ nopedantic.patch)
+sha256sums=('SKIP'
+ 5e4b09cced2c12e592caae20a9ee1723090cae9885ced69205947be4d9385b57)
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ patch -p1 -i "${srcdir}/nopedantic.patch"
+}
build() {
cd "${srcdir}/${_pkgname}"
- sed -i '/-Wnull-dereference/d' configure.ac
autoreconf --install
./configure --prefix=/usr --enable-debug=no
make
diff --git a/nopedantic.patch b/nopedantic.patch
new file mode 100644
index 000000000000..c4a8bc3e977b
--- /dev/null
+++ b/nopedantic.patch
@@ -0,0 +1,15 @@
+diff --git a/configure.ac b/configure.ac
+index 1a0b247c..77640fe9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -95,10 +95,6 @@ AX_CHECK_COMPILE_FLAG([-std=c99],
+ [AX_APPEND_FLAG([-std=c99])],
+ [AC_MSG_NOTICE(No support for -std=c99 flag)]
+ )
+-AX_CHECK_COMPILE_FLAG([-pedantic-errors],
+- [AX_APPEND_FLAG([-pedantic-errors])],
+- [AC_MSG_NOTICE(No support for -pedantic-errors flag)]
+-)
+
+ AX_CFLAGS_GCC_OPTION([-Wall])
+ AX_CFLAGS_GCC_OPTION([-Wextra])