summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhenning mueller2015-07-05 19:51:12 +0200
committerhenning mueller2015-07-05 19:51:12 +0200
commitaeffae1a8f16dd7079ad7de5666048ae032069d4 (patch)
tree26800aaa4d8cbf88da608b00b33cda47e4f15161
downloadaur-aeffae1a8f16dd7079ad7de5666048ae032069d4.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
-rw-r--r--libowfat.install39
3 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f93c8c93498
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libowfat
+ pkgdesc = GPL reimplementation of libdjb
+ pkgver = 0.29
+ pkgrel = 3
+ url = http://www.fefe.de/libowfat/
+ install = libowfat.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = dietlibc
+ conflicts = tinycdb
+ options = staticlibs
+ source = http://dl.fefe.de/libowfat-0.29.tar.bz2
+ sha256sums = 4badbdeed6bef4337f1edd6b86fb7154c5592509c272dcdc09c693161cbc6427
+
+pkgname = libowfat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..748183e62552
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributors:
+# Alexander Ulrich <a.ulrich@student.uni-tuebingen.de>
+# Mildred <silkensedai@online.fr>
+# henning mueller <henning@orgizm.net>
+# Stefan J. Betz <info@stefan-betz.net>
+
+pkgname=libowfat
+pkgver=0.29
+pkgrel=3
+pkgdesc='GPL reimplementation of libdjb'
+arch=(i686 x86_64)
+url=http://www.fefe.de/libowfat/
+makedepends=(dietlibc)
+license=(GPL)
+install=libowfat.install
+conflicts=(tinycdb)
+options=(staticlibs)
+source=(
+ http://dl.fefe.de/$pkgname-$pkgver.tar.bz2
+)
+sha256sums=(
+ 4badbdeed6bef4337f1edd6b86fb7154c5592509c272dcdc09c693161cbc6427
+)
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ DIET= make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ DIET= make prefix=$pkgdir/usr/ LIBDIR=$pkgdir/usr/lib MAN3DIR=$pkgdir/usr/share/man/man3 install
+
+ cd $pkgdir/usr/share/man/man3
+ mv buffer.3 buffer-libowfat.3
+}
diff --git a/libowfat.install b/libowfat.install
new file mode 100644
index 000000000000..a08aef10cbca
--- /dev/null
+++ b/libowfat.install
@@ -0,0 +1,39 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+ echo "The manpage buffer(3) was moved to buffer-libowfat(3) because
+ it conflicts with package openssl"
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ /bin/true
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+$op $*