summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJules Roumieux2017-02-06 07:13:09 +0100
committerJules Roumieux2017-02-06 07:13:09 +0100
commit8f83c581073b540da66dec9c297b2a4c02e57dda (patch)
tree1a33d941ce330a39862916038a45c44d9ea25006
parenta59e9987daa6c6e9d89821f3a09e0c4e1ea26a39 (diff)
downloadaur-8f83c581073b540da66dec9c297b2a4c02e57dda.tar.gz
Updating to 3.0 and cleaning up dependencies
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af71ffddced9..2baa9258fa3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = libp7
pkgdesc = Casio Communication Protocol 7.00 implementation
- pkgver = 2.0
- pkgrel = 5
+ pkgver = 3.0
+ pkgrel = 0
url = https://p7.planet-casio.com
arch = i686
arch = x86_64
- license = GPL2
- makedepends = make>=4.0
- makedepends = gcc>=4.9
+ license = LGPL3
makedepends = asciidoc>=8.6.9
- makedepends = gzip>=1.6
- makedepends = binutils>=2.25
depends = libusb>=1.0
- source = https://p7.planet-casio.com/pub/libp7-2.0.tar.gz
- md5sums = 6d17eea93d338e81be9a7ed1f79e9f14
+ provides = libp7
+ source = https://p7.planet-casio.com/pub/libp7-3.0.tar.gz
+ md5sums = 66ea73a4ff29fa502422a465ce28888d
pkgname = libp7
+
diff --git a/PKGBUILD b/PKGBUILD
index d391a59b2089..30d8aeb11931 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer : Breizh <breizh.craft.98@openmailbox.org>
pkgname=libp7
-pkgver=2.0
-pkgrel=5
+pkgver=3.0
+pkgrel=0
pkgdesc="Casio Communication Protocol 7.00 implementation"
arch=('i686' 'x86_64')
url="https://p7.planet-casio.com"
-license=('GPL2')
+license=('LGPL3')
groups=()
depends=('libusb>=1.0')
-makedepends=('make>=4.0' 'gcc>=4.9' 'asciidoc>=8.6.9' 'gzip>=1.6' 'binutils>=2.25')
+makedepends=('asciidoc>=8.6.9')
optdepends=()
-provides=()
+provides=('libp7')
conflicts=()
replaces=()
backup=()
@@ -19,16 +19,14 @@ install=
changelog=
source=(https://p7.planet-casio.com/pub/${pkgname}-${pkgver}.tar.gz)
noextract=()
-md5sums=('6d17eea93d338e81be9a7ed1f79e9f14')
+md5sums=('66ea73a4ff29fa502422a465ce28888d')
build() {
cd "$pkgname-$pkgver"
- ./configure && make
+ ./configure --udev && make
}
package() {
cd "$pkgname-$pkgver"
make install DESTDIR="$pkgdir"
- mkdir -p $pkgdir/etc/udev/rules.d/
- echo 'ACTION=="add", ATTR{idVendor}=="07cf", ATTR{idProduct}=="6101", MODE="0666"' > $pkgdir/etc/udev/rules.d/60-casio-calculators-usb.rules
}