summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBreizh2016-08-23 14:52:58 +0200
committerBreizh2016-08-23 14:52:58 +0200
commitfd46713636f790601e7dddd68aac9b6892867844 (patch)
treee6f7b65865d56aa1fbb07a9010549807de20cc55
downloadaur-fd46713636f790601e7dddd68aac9b6892867844.tar.gz
Initial release
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..168ac65b0f36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 5.0.1
+# Tue Aug 23 12:49:09 UTC 2016
+pkgbase = libp7
+ pkgdesc = Casio Communication Protocol 7.00 implementation
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://forge.touhey.fr/lib/libp7/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = make
+ makedepends = gcc
+ makedepends = asciidoc
+ makedepends = gzip
+ makedepends = binutils
+ depends = libusb
+ source = https://forge.touhey.fr/lib/libp7/snapshot/libp7-1.2.tar.gz
+ md5sums = da4d02167c7884b7892ef2f709cfb7cc
+
+pkgname = libp7
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e16ab2a64bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer : Breizh <breizh.craft.98@openmailbox.org>
+pkgname=libp7
+pkgver=1.2
+pkgrel=1
+pkgdesc="Casio Communication Protocol 7.00 implementation"
+arch=('i686' 'x86_64')
+url="https://forge.touhey.fr/lib/libp7/"
+license=('GPL2')
+groups=()
+depends=('libusb')
+makedepends=('make' 'gcc' 'asciidoc' 'gzip' 'binutils')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(https://forge.touhey.fr/lib/$pkgname/snapshot/$pkgname-$pkgver.tar.gz)
+noextract=()
+md5sums=('da4d02167c7884b7892ef2f709cfb7cc')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=$pkgdir/usr --udevrulesdir=$pkgdir/etc/udev/rules.d
+ make all all-doc
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make install install-doc
+}