summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 15:54:54 +0200
committerM0Rf302015-06-17 15:54:54 +0200
commitb9857951570bff0f215ec489700be96af40f97bb (patch)
tree082cfbe238390de64079c1b017027a19e7e24268
downloadaur-b9857951570bff0f215ec489700be96af40f97bb.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
-rw-r--r--libpam-google-authenticator.install5
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26adee555179
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libpam-google-authenticator
+ pkgdesc = PAM module for google authenticator app
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://code.google.com/p/google-authenticator/
+ install = libpam-google-authenticator.install
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = pam
+ optdepends = qrencode: scannable QR codes for google auth phone app
+ conflicts = google-authenticator-libpam-git
+ conflicts = google-authenticator-libpam-hg
+ source = http://google-authenticator.googlecode.com/files/libpam-google-authenticator-1.0-source.tar.bz2
+ md5sums = 9db0194fcae26a67dcedbcd49397e95e
+
+pkgname = libpam-google-authenticator
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a616913e61f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: M0Rf30
+
+pkgname=libpam-google-authenticator
+pkgver=1.0
+pkgrel=1
+pkgdesc='PAM module for google authenticator app'
+arch=('i686' 'x86_64')
+url="https://code.google.com/p/google-authenticator/"
+license=('Apache')
+depends=('pam')
+optdepends=('qrencode: scannable QR codes for google auth phone app')
+conflicts=('google-authenticator-libpam-git' 'google-authenticator-libpam-hg')
+source=("http://google-authenticator.googlecode.com/files/${pkgname}-${pkgver}-source.tar.bz2")
+install=${pkgname}.install
+
+build() {
+ cd $srcdir/${pkgname}-${pkgver}
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ install -D -m755 pam_google_authenticator.so "$pkgdir/usr/lib/security/pam_google_authenticator.so"
+ install -D -m755 google-authenticator "$pkgdir/usr/bin/google-authenticator"
+}
+
+md5sums=('9db0194fcae26a67dcedbcd49397e95e')
diff --git a/libpam-google-authenticator.install b/libpam-google-authenticator.install
new file mode 100644
index 000000000000..fc91fa2bdfe9
--- /dev/null
+++ b/libpam-google-authenticator.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo "Add this line to your PAM configuration file:"
+ echo "auth required pam_google_authenticator.so"
+ echo "Run the "google-authenticator" binary to create a new secret key in your home directory."
+}