summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuke Short2022-07-11 22:56:42 -0600
committerLuke Short2022-07-11 22:56:42 -0600
commit1498d1147b67adcb695accbcfecac666b66bdcd3 (patch)
tree454471cf307d340363c7c4852fe5f74705692344
parent223f99efd20b3fb34a1ea724fd34454c81a8c6ff (diff)
downloadaur-1498d1147b67adcb695accbcfecac666b66bdcd3.tar.gz
Revert "Fixed PKGBUILD regarding the tempfix of cd into directory. Now compiles with no errors"
This reverts commit 223f99efd20b3fb34a1ea724fd34454c81a8c6ff.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbe5beb06483..687fc9f9d09c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -32,7 +32,7 @@ pkgbase = libpamac-full
conflicts = libpamac-full-dev
options = !emptydirs
source = git+https://gitlab.manjaro.org/applications/libpamac.git
- sha256sums = SKIP
+ sha256sums = 8f05c025934756f77a1a8f00e3ae5abb710fda078876f8e44e0b300fd49d1347
pkgname = libpamac-full
backup = etc/pamac.conf
diff --git a/PKGBUILD b/PKGBUILD
index 5b1ed91856c3..f75f9d281b1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,14 +15,13 @@ options=(!emptydirs)
conflicts=('libpamac-aur' 'libpamac-flatpak' 'libpamac' 'libpamac-full-dev')
#Temp Fix
source=(git+https://gitlab.manjaro.org/applications/libpamac.git)
-sha256sums=('SKIP')
+
#Stable
#source=(https://gitlab.manjaro.org/applications/libpamac/-/archive/$pkgver/$_pkgname-$pkgver.tar.bz2)
-#sha256sums=('8f05c025934756f77a1a8f00e3ae5abb710fda078876f8e44e0b300fd49d1347')
+sha256sums=('8f05c025934756f77a1a8f00e3ae5abb710fda078876f8e44e0b300fd49d1347')
build() {
- cd libpamac
-# cd $_pkgname-$pkgver
+ cd $_pkgname-$pkgver
mkdir -p builddir
cd builddir
meson setup --prefix=/usr --sysconfdir=/etc -Denable-snap=true -Denable-flatpak=true --buildtype=release
@@ -32,8 +31,7 @@ build() {
package() {
backup=('etc/pamac.conf')
- cd libpamac
-# cd $_pkgname-$pkgver
+ cd $_pkgname-$pkgver
cd builddir
DESTDIR="$pkgdir" ninja install
}