summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2021-11-06 13:32:07 +0100
committerFrederic Bezies2021-11-06 13:32:07 +0100
commit235511006229dced7fa494defb9489226a62d578 (patch)
treebb032129ae587df8924b9145f420df3aef35504b
downloadaur-235511006229dced7fa494defb9489226a62d578.tar.gz
initial import
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD39
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0be1ee38357
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = libpamac-git
+ pkgdesc = Library for Pamac package manager based on libalpm - git version
+ pkgver = 1.1.3.r6.g25b0dba
+ pkgrel = 1
+ url = https://gitlab.manjaro.org/applications/libpamac
+ arch = i686
+ arch = pentium4
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = gettext
+ makedepends = itstool
+ makedepends = vala
+ makedepends = meson
+ makedepends = ninja
+ makedepends = gobject-introspection
+ makedepends = xorgproto
+ makedepends = asciidoc
+ depends = pacman>=6.0
+ depends = pacman<6.1
+ depends = appstream-glib
+ depends = polkit
+ depends = archlinux-appstream-data-pamac
+ conflicts = libpamac-aur
+ conflicts = libpamac-full
+ conflicts = libpamac-full-dev
+ conflicts = libpamac
+ options = !emptydirs
+ source = git+https://gitlab.manjaro.org/applications/libpamac.git
+ sha256sums = SKIP
+
+pkgname = libpamac-git
+ backup = etc/pamac.conf
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84bf69c18ce0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+
+pkgname=libpamac-git
+_pkgname=libpamac
+pkgver=1.1.3.r6.g25b0dba
+pkgrel=1
+pkgdesc="Library for Pamac package manager based on libalpm - git version"
+arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://gitlab.manjaro.org/applications/libpamac"
+license=('GPL3')
+depends=('pacman>=6.0' 'pacman<6.1' 'appstream-glib' 'polkit' 'archlinux-appstream-data-pamac')
+makedepends=('gettext' 'itstool' 'vala' 'meson' 'ninja' 'gobject-introspection' 'xorgproto' 'asciidoc')
+options=(!emptydirs)
+conflicts=('libpamac-aur' 'libpamac-full' 'libpamac-full-dev' 'libpamac')
+source=(git+https://gitlab.manjaro.org/applications/libpamac.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | cut -c2-48
+}
+
+build() {
+ cd $_pkgname
+ mkdir -p builddir
+ cd builddir
+ meson setup --prefix=/usr --sysconfdir=/etc --buildtype=release
+ # build
+ ninja
+}
+
+package() {
+ backup=('etc/pamac.conf')
+ cd $_pkgname
+ cd builddir
+ DESTDIR="$pkgdir" ninja install
+}
+
+#vim:set ts=2 sw=2 et: