summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukáš Jirkovský2015-07-02 21:15:01 +0200
committerLukáš Jirkovský2015-07-02 21:15:01 +0200
commit23385a5dfee1be052b3ff77af31e9cfc5185e5c1 (patch)
tree7101899d3fa350dcb16a58de4106a9e6bef5a3e8
downloadaur-23385a5dfee1be052b3ff77af31e9cfc5185e5c1.tar.gz
initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..698d25585842
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libpano13-hg
+ pkgdesc = Basic library to calculate panoramical pictures - core functions of the panotools
+ pkgver = 826.7339b1014e88
+ pkgrel = 1
+ url = http://panotools.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = mercurial
+ makedepends = cmake
+ depends = libpng
+ depends = libtiff
+ provides = libpano13
+ conflicts = libpano13
+ options = !libtool
+ source = hg+http://hg.code.sf.net/p/panotools/libpano13
+ md5sums = SKIP
+
+pkgname = libpano13-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98b1f312040a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+pkgname=libpano13-hg
+pkgver=826.7339b1014e88
+pkgrel=1
+pkgdesc="Basic library to calculate panoramical pictures - core functions of the panotools"
+url="http://panotools.sourceforge.net/"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('libpng' 'libtiff')
+makedepends=('mercurial' 'cmake')
+provides=('libpano13')
+conflicts=('libpano13')
+options=(!libtool)
+source=('hg+http://hg.code.sf.net/p/panotools/libpano13')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/libpano13"
+ echo $(hg identify -n).$(hg identify -i)
+}
+
+build() {
+ cd "$srcdir/libpano13"
+
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+ cd "$srcdir/libpano13"
+ make DESTDIR="$pkgdir" install
+}