summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2015-12-05 17:18:15 +0100
committerMattias Andrée2015-12-05 17:18:15 +0100
commit0bf453d9d06ac6902d0bd038687659a87686f278 (patch)
treea12900476ebcc7819a338eaf4ad5b5a2cb202c1c
parent7874a5c8f8c0246ca3af409fbc76c610e33f240c (diff)
downloadaur-0bf453d9d06ac6902d0bd038687659a87686f278.tar.gz
Update to 1449331105
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 026a536adb12..de3d72ebe1d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libpassphrase
pkgdesc = Personalisable library for TTY passphrase reading
- pkgver = 1428445396
+ pkgver = 1449331105
pkgrel = 1
url = https://github.com/GNU-Pony/libpassphrase
install = libpassphrase.install
@@ -14,8 +14,8 @@ pkgbase = libpassphrase
makedepends = texinfo
makedepends = gzip
depends = glibc
- source = https://github.com/GNU-Pony/libpassphrase/archive/1428445396.tar.gz
- sha256sums = 6c721c89aeac150a990591193f73e6625a54fbd5e79d709c0adddc3b5ba4c5ca
+ source = https://github.com/GNU-Pony/libpassphrase/archive/1449331105.tar.gz
+ sha256sums = 76044a7af93dd6a956c6fb9a13af711a2c90b260420a2bf1b272d624deefafb7
pkgname = libpassphrase
diff --git a/PKGBUILD b/PKGBUILD
index 09a26db427ba..4100218e7d6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
pkgname=libpassphrase
-pkgver=1428445396
+pkgver=1449331105
pkgrel=1
pkgdesc="Personalisable library for TTY passphrase reading"
url="https://github.com/GNU-Pony/libpassphrase"
@@ -11,7 +11,7 @@ depends=(glibc)
makedepends=(make coreutils gcc texinfo gzip)
install=libpassphrase.install
source=("${url}/archive/${pkgver}.tar.gz")
-sha256sums=(6c721c89aeac150a990591193f73e6625a54fbd5e79d709c0adddc3b5ba4c5ca)
+sha256sums=(76044a7af93dd6a956c6fb9a13af711a2c90b260420a2bf1b272d624deefafb7)
build() {
@@ -30,16 +30,20 @@ build() {
options+=( PASSPHRASE_DEDICATED ) # Enable use of dedicated keys
options+=( DEFAULT_INSERT ) # Use insert mode as default
options+=( PASSPHRASE_INVALID ) # Prevent duplication of non-initialised memory
- ## see `info libpassphrase configuring` for details
+ options+=( PASSPHRASE_METER ) # Enable strength meter for new passphrases
+ ## see `info '(libpassphrase)' configuring` for details
star_char="*"
text_empty="(empty)"
text_not_empty="(not empty)"
+ text_strength="Strength:"
make PKGNAME="${pkgname}" OPTIONS="${options[*]}" \
PASSPHRASE_STAR_CHAR="${star_char}" \
PASSPHRASE_TEXT_EMPTY="${text_empty}" \
- PASSPHRASE_TEXT_NOT_EMPTY="${text_not_empty}"
+ PASSPHRASE_TEXT_NOT_EMPTY="${text_not_empty}" \
+ PASSPHRASE_TEXT_STRENGTH="${text_strength}"
+ ## it is also possible to add PASSPHRASE_STRENGTH_LIMITS_HEADER
}
package() {