summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2015-06-11 19:08:32 +0200
committerMattias Andrée2015-06-11 19:08:32 +0200
commit7874a5c8f8c0246ca3af409fbc76c610e33f240c (patch)
tree99bc65555a7d4c4792a4229ad01945905f3707a5
downloadaur-7874a5c8f8c0246ca3af409fbc76c610e33f240c.tar.gz
Initial import, version 1428445396
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD53
-rw-r--r--libpassphrase.install20
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..026a536adb12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = libpassphrase
+ pkgdesc = Personalisable library for TTY passphrase reading
+ pkgver = 1428445396
+ pkgrel = 1
+ url = https://github.com/GNU-Pony/libpassphrase
+ install = libpassphrase.install
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ license = GPL3
+ makedepends = make
+ makedepends = coreutils
+ makedepends = gcc
+ makedepends = texinfo
+ makedepends = gzip
+ depends = glibc
+ source = https://github.com/GNU-Pony/libpassphrase/archive/1428445396.tar.gz
+ sha256sums = 6c721c89aeac150a990591193f73e6625a54fbd5e79d709c0adddc3b5ba4c5ca
+
+pkgname = libpassphrase
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09a26db427ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=libpassphrase
+pkgver=1428445396
+pkgrel=1
+pkgdesc="Personalisable library for TTY passphrase reading"
+url="https://github.com/GNU-Pony/libpassphrase"
+arch=(i686 x86_64 armv6h)
+license=(GPL3)
+depends=(glibc)
+makedepends=(make coreutils gcc texinfo gzip)
+install=libpassphrase.install
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(6c721c89aeac150a990591193f73e6625a54fbd5e79d709c0adddc3b5ba4c5ca)
+
+
+build() {
+ cd "${srcdir}/libpassphrase-${pkgver}"
+
+ options=()
+ #options+=( PASSPHRASE_ECHO ) # Do not hide the passphrase
+ #options+=( PASSPHRASE_STAR ) # Use '*' for each character instead of no echo
+ options+=( PASSPHRASE_TEXT ) # Use '(empty)' and not '(not empty)' instead of no echo
+ #options+=( PASSPHRASE_REALLOC ) # Soften security by using `realloc`
+ options+=( PASSPHRASE_MOVE ) # Enable move of point
+ options+=( PASSPHRASE_INSERT ) # Enable insert mode
+ options+=( PASSPHRASE_OVERRIDE ) # Enable override mode
+ options+=( PASSPHRASE_DELETE ) # Enable reversed erase command
+ options+=( PASSPHRASE_CONTROL ) # Enable use of control key combinations
+ options+=( PASSPHRASE_DEDICATED ) # Enable use of dedicated keys
+ options+=( DEFAULT_INSERT ) # Use insert mode as default
+ options+=( PASSPHRASE_INVALID ) # Prevent duplication of non-initialised memory
+ ## see `info libpassphrase configuring` for details
+
+ star_char="*"
+ text_empty="(empty)"
+ text_not_empty="(not empty)"
+
+ make PKGNAME="${pkgname}" OPTIONS="${options[*]}" \
+ PASSPHRASE_STAR_CHAR="${star_char}" \
+ PASSPHRASE_TEXT_EMPTY="${text_empty}" \
+ PASSPHRASE_TEXT_NOT_EMPTY="${text_not_empty}"
+}
+
+package() {
+ cd "${srcdir}/libpassphrase-${pkgver}"
+
+ make PKGNAME="${pkgname}" DESTDIR="${pkgdir}" install
+
+ _dir="${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -sf -- "/usr/share/licenses/common/GPL3" "${_dir}/LICENSE"
+}
+
diff --git a/libpassphrase.install b/libpassphrase.install
new file mode 100644
index 000000000000..f69bfba0cd39
--- /dev/null
+++ b/libpassphrase.install
@@ -0,0 +1,20 @@
+_file="libpassphrase"
+
+infodir="usr/share/info"
+file="${_file}.info"
+
+
+post_install() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info --delete -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+