summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel-Andrew Pollo Guilbert2019-06-04 07:59:38 -0400
committerGabriel-Andrew Pollo Guilbert2019-06-04 07:59:38 -0400
commit35a94a3259e6dee7151b74d1d955fa608da6775f (patch)
tree7305a179d0752726d60dd5d6a0115ed6f6bc701e
parent0a129b4017a7990a5a474a9e223745bb5a9ab913 (diff)
downloadaur-35a94a3259e6dee7151b74d1d955fa608da6775f.tar.gz
Update to 4.3.1
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c7435572027b..c0762b2b0e50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gabriel-Andrew Pollo-Guilbert <gabrielpolloguilbert@gmail.com>
pkgname=libpcanbasic
-pkgver=4.2.2
+pkgver=4.3.1
pkgrel=1
pkgdesc='API for the development of applications with PEAK CAN connection for Linux '
arch=('x86_64')
@@ -9,30 +9,30 @@ url='https://www.peak-system.com/PCAN-USB.199.0.html'
license=('LGPL')
depends=('peak-linux-headers')
source=(
- "https://www.peak-system.com/produktcd/Develop/PC%20interfaces/Linux/PCAN-Basic_API_for_Linux/PCAN_Basic_Linux-${pkgver}.tar.gz"
+ "https://www.peak-system.com/produktcd/Develop/PC%20interfaces/Linux/PCAN-Basic_API_for_Linux/PCAN-Basic_Linux-${pkgver}.tar.gz"
)
sha256sums=(
- "95b1916a28f9dd02d2840da8369558a7e5a3a977b9e9f1046ff67616dcc8977b"
+ "b88f5a73ebe6a52a58f005ae4a205c937ed317445a95de58b6872af69f1f9524"
)
prepare() {
# go into source directory
- cd "PCAN_Basic_Linux-${pkgver}/pcanbasic"
+ cd "PCAN-Basic_Linux-${pkgver}/libpcanbasic/pcanbasic"
# add new install target into the makefile
echo -e '' >> 'Makefile_latest.mk'
echo -e 'install-archlinux:' >> 'Makefile_latest.mk'
echo -e '\tcp $(TARGET) $(DESTDIR)/$(LIBPATH)/$(TARGET)' >> 'Makefile_latest.mk'
echo -e '\t$(LN) /$(LIBPATH)/$(TARGET) $(DESTDIR)/$(LIBPATH)/$(SONAME)' >> 'Makefile_latest.mk'
- echo -e '\t$(LN) /$(LIBPATH)/$(TARGET) $(DESTDIR)/$(LIBPATH)/$(SONAME_OLD)' >> 'Makefile_latest.mk'
- echo -e '\t$(LN) /$(LIBPATH)/$(SONAME) $(DESTDIR)/$(LIBPATH)/$(LDNAME)' >> 'Makefile_latest.mk'
- echo -e '\tcp PCANBasic.h $(DESTDIR)/usr/include/PCANBasic.h' >> 'Makefile_latest.mk'
- echo -e '\tchmod 644 $(DESTDIR)/usr/include/PCANBasic.h' >> 'Makefile_latest.mk'
+ echo -e '\t$(LN) /$(LIBPATH)/$(TARGET) $(DESTDIR)/$(LIBPATH)/$(SONAME_OLD)' >> 'Makefile_latest.mk'
+ echo -e '\t$(LN) /$(LIBPATH)/$(SONAME) $(DESTDIR)/$(LIBPATH)/$(LDNAME)' >> 'Makefile_latest.mk'
+ echo -e '\tcp PCANBasic.h $(DESTDIR)/usr/include/PCANBasic.h' >> 'Makefile_latest.mk'
+ echo -e '\tchmod 644 $(DESTDIR)/usr/include/PCANBasic.h' >> 'Makefile_latest.mk'
}
build() {
# go into source directory
- cd "PCAN_Basic_Linux-${pkgver}/pcanbasic"
+ cd "PCAN-Basic_Linux-${pkgver}/libpcanbasic/pcanbasic"
# build libpcanbasic
make clean
@@ -41,7 +41,7 @@ build() {
package() {
# go into source directory
- cd "PCAN_Basic_Linux-${pkgver}/pcanbasic"
+ cd "PCAN-Basic_Linux-${pkgver}/libpcanbasic/pcanbasic"
# create directories
install -d "${pkgdir}/usr/lib"