summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2015-06-14 04:13:28 +0300
committerDet2015-06-14 04:14:15 +0300
commit348d5cb2c8bb7d2c6c6b7e9016fa9573e9e44684 (patch)
tree52558a402e81ea860f5d9fbfbc0ace3af078c4b4
downloadaur-348d5cb2c8bb7d2c6c6b7e9016fa9573e9e44684.tar.gz
Initial import: 0.13.2.9.r277.g9b1bf11-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..036c174c5916
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libpciaccess-git
+ pkgdesc = X11 PCI access library - Git version
+ pkgver = 0.13.2.9.r277.g9b1bf11
+ pkgrel = 1
+ url = http://cgit.freedesktop.org/xorg/lib/libpciaccess/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ makedepends = xorg-util-macros
+ provides = libpciaccess=0.13.2.9.r277.g9b1bf11
+ conflicts = libpciaccess
+ options = !libtool
+ source = git://anongit.freedesktop.org/xorg/lib/libpciaccess
+ md5sums = SKIP
+
+pkgname = libpciaccess-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00986785eb43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Det <nimetonmaili g-mail>
+# Contributor: Matt Parnell /ilikenwf <parwok@gmail.com>
+# Contributor: Jonathan <eyeswide@gmail.com>
+# Based on [extra]'s libpciaccess: https://projects.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/libpciaccess
+
+_pkgname=libpciaccess
+pkgname=$_pkgname-git
+pkgver=0.13.2.9.r277.g9b1bf11
+pkgrel=1
+pkgdesc="X11 PCI access library - Git version"
+arch=('i686' 'x86_64')
+url="http://cgit.freedesktop.org/xorg/lib/$_pkgname/"
+license=('custom')
+makedepends=('git' 'xorg-util-macros')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+options=('!libtool')
+source=("git://anongit.freedesktop.org/xorg/lib/$_pkgname")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+
+ echo $(git describe --long | cut -d "-" -f2-3 | tr - .).r$(git rev-list HEAD --count).$(git describe --long | cut -d "-" -f4)
+}
+
+build() {
+ cd $_pkgname
+
+ msg2 "Starting autogen.sh..."
+ ./autogen.sh --prefix=/usr
+
+ msg2 "Starting make..."
+ make
+}
+
+package() {
+ cd $_pkgname
+
+ msg2 "Starting make install..."
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$_pkgname/COPYING"
+}