summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-08-04 16:24:08 +0000
committerDaniel Bermond2018-08-04 16:24:08 +0000
commita4ee52571cee86379eb01b3826d36ec95ddd43b0 (patch)
tree6786bbc8e4ade2db3a113e30c9e44ca01871505b
parent0e8bb6a3f11211eba1b679300bed32adeac273c2 (diff)
downloadaur-a4ee52571cee86379eb01b3826d36ec95ddd43b0.tar.gz
Cosmetic changes
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD57
2 files changed, 35 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c1a026c840a..a04a373e03d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = libpciaccess-git
- pkgdesc = X11 PCI access library - Git version
- pkgver = 0.13.2.9.r277.g9b1bf11
+ pkgdesc = X11 PCI access library (git version)
+ pkgver = 0.14.r0.g13854f6
pkgrel = 1
url = http://cgit.freedesktop.org/xorg/lib/libpciaccess/
+ arch = i686
arch = x86_64
license = custom
makedepends = git
makedepends = xorg-util-macros
- provides = libpciaccess=0.13.2.9.r277.g9b1bf11
+ depends = glibc
+ provides = libpciaccess
conflicts = libpciaccess
- options = !libtool
- source = git://anongit.freedesktop.org/xorg/lib/libpciaccess
- md5sums = SKIP
+ source = libpciaccess-git::git://anongit.freedesktop.org/xorg/lib/libpciaccess
+ sha256sums = SKIP
pkgname = libpciaccess-git
diff --git a/PKGBUILD b/PKGBUILD
index aa7a7c629628..9d8736a3760e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,43 @@
-# Maintainer: Det <nimetonmaili g-mail>
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Contributor: Det <nimetonmaili g-mail>
# Contributor: Matt Parnell /ilikenwf <parwok@gmail.com>
# Contributor: Jonathan <eyeswide@gmail.com>
-# Based on [extra]'s libpciaccess: https://projects.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/libpciaccess
-_pkgname=libpciaccess
-pkgname=$_pkgname-git
-pkgver=0.13.2.9.r277.g9b1bf11
+pkgname=libpciaccess-git
+pkgver=0.14.r0.g13854f6
pkgrel=1
-pkgdesc="X11 PCI access library - Git version"
-arch=('x86_64')
-url="http://cgit.freedesktop.org/xorg/lib/$_pkgname/"
+pkgdesc='X11 PCI access library (git version)'
+arch=('i686' 'x86_64')
+url='http://cgit.freedesktop.org/xorg/lib/libpciaccess/'
license=('custom')
+depends=('glibc')
makedepends=('git' 'xorg-util-macros')
-provides=("$_pkgname=$pkgver")
-conflicts=("$_pkgname")
-options=('!libtool')
-source=("git://anongit.freedesktop.org/xorg/lib/$_pkgname")
-md5sums=('SKIP')
+provides=('libpciaccess')
+conflicts=('libpciaccess')
+source=("$pkgname"::'git://anongit.freedesktop.org/xorg/lib/libpciaccess')
+sha256sums=('SKIP')
pkgver() {
- cd $_pkgname
-
- echo $(git describe --long | cut -d "-" -f2-3 | tr - .).r$(git rev-list HEAD --count).$(git describe --long | cut -d "-" -f4)
+ cd "$pkgname"
+
+ # git, tags available
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^libpciaccess\.//;s/^v//'
}
build() {
- cd $_pkgname
-
- msg2 "Starting autogen.sh..."
- ./autogen.sh --prefix=/usr
-
- msg2 "Starting make..."
- make
+ cd "$pkgname"
+
+ ./autogen.sh \
+ --prefix='/usr' \
+ --sysconfdir='/etc'
+
+ make
}
package() {
- cd $_pkgname
-
- msg2 "Starting make install..."
- make DESTDIR="$pkgdir" install
-
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$_pkgname/COPYING"
+ cd "$pkgname"
+
+ make DESTDIR="$pkgdir" install
+
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}