summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-07 13:40:48 +0100
committerBartłomiej Piotrowski2018-01-07 13:40:48 +0100
commite728c22e33a4045f36490642cba3bacf5c73cc14 (patch)
tree1442074fe1752b9c2cbf5ffc1dc65b5a59df11ee
parentdd5678b27508c96618c6a3ebbeb162fffd1d6322 (diff)
downloadaur-e728c22e33a4045f36490642cba3bacf5c73cc14.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD28
2 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59e94f894b0c..35f4aa712957 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = libpcl
pkgdesc = The Portable Coroutine Library (PCL) implements the low level functionality for coroutines
pkgver = 1.12
- pkgrel = 2
+ pkgrel = 3
url = http://xmailserver.org/libpcl.html
- arch = i686
arch = x86_64
license = GPL2
depends = glibc
source = http://xmailserver.org/pcl-1.12.tar.gz
- md5sums = 816d394743d8ab1b3e20af1efebb093d
+ sha1sums = a206c8fb5a96e65005f414ac46aeccd4b3603c8d
pkgname = libpcl
diff --git a/PKGBUILD b/PKGBUILD
index 52ccf5518a36..44bec0fcc004 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
-# Maintainer: Brian Bidlock <bidulock@openss7.org>
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+# Contributor: Brian Bidlock <bidulock@openss7.org>
+
pkgname=libpcl
-_libname=pcl
pkgver=1.12
-pkgrel=2
-pkgdesc="The Portable Coroutine Library (PCL) implements the low level functionality for coroutines"
-license=("GPL2")
-url="http://xmailserver.org/libpcl.html"
-arch=('i686' 'x86_64')
-depends=('glibc')
-source=("http://xmailserver.org/$_libname-$pkgver.tar.gz")
-md5sums=('816d394743d8ab1b3e20af1efebb093d')
+pkgrel=3
+pkgdesc='The Portable Coroutine Library (PCL) implements the low level functionality for coroutines'
+license=(GPL2)
+url='http://xmailserver.org/libpcl.html'
+arch=(x86_64)
+depends=(glibc)
+source=(http://xmailserver.org/pcl-$pkgver.tar.gz)
+sha1sums=('a206c8fb5a96e65005f414ac46aeccd4b3603c8d')
build() {
- cd "$srcdir/$_libname-$pkgver"
+ cd pcl-$pkgver
./configure --prefix=/usr
make
}
package() {
- cd "$srcdir/$_libname-$pkgver"
+ cd pcl-$pkgver
make DESTDIR="$pkgdir" install
}
-
-