summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Kauselmann2024-05-09 12:51:36 +0200
committerFelix Kauselmann2024-05-09 12:51:36 +0200
commit95d86928a511f9f21594c8b1b4c7600d3b69a4a4 (patch)
tree096824ba1f217da7ebe4584271ebd1028a1410c7
parent3e96777216fb9ff7f10625a3d132f7caef52af73 (diff)
downloadaur-95d86928a511f9f21594c8b1b4c7600d3b69a4a4.tar.gz
Update to v6367
This includes a workaround for a problem with the upstream build dependencies
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5980ef1be16b..3f3aaf0ebba0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libpdfium-nojs
pkgdesc = Open-source PDF rendering engine.
- pkgver = 6261.r0.4c4f9ab25d
+ pkgver = 6367.r1.7b90b15a21
pkgrel = 1
url = https://pdfium.googlesource.com/pdfium/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 5fdd819449aa..9c588314619b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Felix Kauselmann <licorn@gmail.com>
pkgname=libpdfium-nojs
-pkgver=6261.r0.4c4f9ab25d
+pkgver=6367.r1.7b90b15a21
pkgrel=1
pkgdesc="Open-source PDF rendering engine."
arch=('x86_64')
@@ -55,8 +55,14 @@ prepare() {
# Extract build repo revision needed from DEPS file and do a checkout
cd "$srcdir/pdfium/build"
- git checkout $(awk '/build_revision/ {print substr($2,2,40)}' $srcdir/pdfium/DEPS) -q
-
+ # Use a newer build revision to work around a build system bug in v6367
+ if [[ $chrome_version -gt 6367 ]]
+ then
+ git checkout $(awk '/build_revision/ {print substr($2,2,40)}' $srcdir/pdfium/DEPS) -q
+ else
+ git checkout bbc1efa4ce09a306328744c508d208407d5978a6 -q
+ fi
+
# Extract abseil-cpp repo revision needed from DEPS file and do a checkout
cd "$srcdir/pdfium/third_party/abseil-cpp"
git checkout $(awk '/abseil_revision/ {print substr($2,2,40)}' $srcdir/pdfium/DEPS) -q
@@ -104,6 +110,7 @@ build() {
'use_system_lcms2=true'
'use_system_libpng=true'
'use_custom_libcxx=false'
+ 'enable_safe_libcxx=false'
'pdf_is_standalone = true'
'use_system_libopenjpeg2 = true'
'is_component_build = true'