summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Kauselmann2018-10-18 22:45:51 +0200
committerFelix Kauselmann2018-10-18 22:45:51 +0200
commitb93101aabd5c9c7c766b84223caca6ded5552fd9 (patch)
tree894ca9c6dd196e7d2a8827415d33029923c88a8d
parent28428987bcce17ef32646105d1ac1ab73617b8bb (diff)
downloadaur-b93101aabd5c9c7c766b84223caca6ded5552fd9.tar.gz
Update to 3538
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--openjpeg.patch14
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e053ddc79249..8cb791d87f19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# So Sep 16 11:08:37 UTC 2018
+# Thu Oct 18 20:44:52 UTC 2018
pkgbase = libpdfium-nojs
pkgdesc = Open-source PDF rendering engine.
- pkgver = 3497.r2.139f7fbf60
+ pkgver = 3538.r3.13b08aa11d
pkgrel = 1
url = https://pdfium.googlesource.com/pdfium/
arch = x86_64
@@ -27,7 +27,7 @@ pkgbase = libpdfium-nojs
md5sums = SKIP
md5sums = SKIP
md5sums = 7fbbe2baf9a1fed80ad74278e901fa0e
- md5sums = bbab1612841a1b2b0802ef75f02b9daf
+ md5sums = a57e7180e3931d74b60f05d653b6bbe3
pkgname = libpdfium-nojs
diff --git a/PKGBUILD b/PKGBUILD
index 902aa22ee7df..f22f4288ec50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Felix Kauselmann <licorn at gmail dot com>
pkgname=libpdfium-nojs
-pkgver=3497.r2.139f7fbf60
+pkgver=3538.r3.13b08aa11d
pkgrel=1
pkgdesc="Open-source PDF rendering engine."
arch=('x86_64')
@@ -23,7 +23,7 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'7fbbe2baf9a1fed80ad74278e901fa0e'
- 'bbab1612841a1b2b0802ef75f02b9daf')
+ 'a57e7180e3931d74b60f05d653b6bbe3')
pkgver() {
diff --git a/openjpeg.patch b/openjpeg.patch
index b666a09669e7..e7490236b837 100644
--- a/openjpeg.patch
+++ b/openjpeg.patch
@@ -3,7 +3,7 @@ author: Michael Gilbert <mgilbert@debian.org>
--- a/third_party/pdfium/third_party/BUILD.gn
+++ b/third_party/pdfium/third_party/BUILD.gn
-@@ -366,39 +366,11 @@ config("fx_libopenjpeg_warnings") {
+@@ -367,39 +367,11 @@ config("fx_libopenjpeg_warnings") {
}
}
@@ -59,9 +59,9 @@ author: Michael Gilbert <mgilbert@debian.org>
class CPDF_ColorSpace;
---- a/third_party/pdfium/core/fxcodec/codec/fx_codec_jpx_opj.cpp
-+++ b/third_party/pdfium/core/fxcodec/codec/fx_codec_jpx_opj.cpp
-@@ -16,8 +16,6 @@
+--- a/third_party/pdfium/core/fxcodec/codec/ccodec_jpxmodule.cpp
++++ b/third_party/pdfium/core/fxcodec/codec/ccodec_jpxmodule.cpp
+@@ -17,8 +17,6 @@
#include "core/fxcrt/fx_memory.h"
#include "core/fxcrt/fx_safe_types.h"
#include "third_party/base/ptr_util.h"
@@ -70,7 +70,7 @@ author: Michael Gilbert <mgilbert@debian.org>
namespace {
-@@ -514,7 +512,6 @@ bool CJPX_Decoder::Init(pdfium::span<con
+@@ -515,7 +513,6 @@ bool CJPX_Decoder::Init(pdfium::span<con
return false;
m_Image = pTempImage;
@@ -78,7 +78,7 @@ author: Michael Gilbert <mgilbert@debian.org>
if (!m_Parameters.nb_tile_to_decode) {
if (!opj_set_decode_area(m_Codec.Get(), m_Image.Get(), m_Parameters.DA_x0,
-@@ -548,7 +545,7 @@ bool CJPX_Decoder::Init(pdfium::span<con
+@@ -549,7 +546,7 @@ bool CJPX_Decoder::Init(pdfium::span<con
// TODO(palmer): Using |opj_free| here resolves the crash described in
// https://crbug.com/737033, but ultimately we need to harmonize the
// memory allocation strategy across OpenJPEG and its PDFium callers.
@@ -108,7 +108,7 @@ author: Michael Gilbert <mgilbert@debian.org>
"PNG_PREFIX",
"PNG_USE_READ_MACROS",
]
-@@ -75,7 +74,6 @@ config("pdfium_core_config") {
+@@ -78,7 +77,6 @@ config("pdfium_core_config") {
if (is_linux) {
if (current_cpu == "x64") {
defines += [ "_FX_CPU_=_FX_X64_" ]