summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Kauselmann2023-12-03 17:21:55 +0100
committerFelix Kauselmann2023-12-03 17:21:55 +0100
commitd674c6c8257cac2a3d5cddbbb4e6a9783f3415ba (patch)
tree7960e445b7c856bdf10fb4a289a1bd083a4c9804
parent8f39ca692fd1c86409de4bbb25bff67b1d2f1b3d (diff)
downloadaur-d674c6c8257cac2a3d5cddbbb4e6a9783f3415ba.tar.gz
Fix chrome version and update to v6045
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63a74fea4487..5e6f1de72d80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libpdfium-nojs
pkgdesc = Open-source PDF rendering engine.
- pkgver = 5993.r1.6e55da0c45
+ pkgver = 6045.r1.2e2cfb0399
pkgrel = 1
url = https://pdfium.googlesource.com/pdfium/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 5f16bcfb0b63..e70e0a088678 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -44,12 +44,14 @@ prepare() {
# Pdfium is developed alongside Chromium and does not provide releases
# Upstream recommends using Chromium's dev channels instead
- # Extract pdfium branch name used in stable channel from omahaproxy and do
+ # Extract pdfium branch name used in stable channel from chrome version history and do
# a checkout
- git checkout "chromium/$(curl https://omahaproxy.appspot.com/linux?channel=stable | cut -d'.' -f 3)"
+
+ chrome_version="$(curl https://versionhistory.googleapis.com/v1/chrome/platforms/linux/channels/stable/versions/all/releases | grep 'version' | head -1 | cut -d'.' -f 3)"
+ # chrome_version="$(curl https://versionhistory.googleapis.com/v1/chrome/platforms/linux/channels/beta/versions/all/releases | grep 'version' | head -1 | cut -d'.' -f 3)"
+ # chrome_version="$(curl https://versionhistory.googleapis.com/v1/chrome/platforms/linux/channels/dev/versions/all/releases | grep 'version' | head -1 | cut -d'.' -f 3)"
- # git checkout "chromium/$(curl https://omahaproxy.appspot.com/linux?channel=beta | cut -d'.' -f 3)"
- # git checkout "chromium/$(curl https://omahaproxy.appspot.com/linux?channel=dev | cut -d'.' -f 3)"
+ git checkout "chromium/$chrome_version"
# Extract build repo revision needed from DEPS file and do a checkout
cd "$srcdir/pdfium/build"