summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Kauselmann2021-09-10 19:21:29 +0200
committerFelix Kauselmann2021-09-10 19:21:29 +0200
commitda7bfd3e156e8ef8e08ac3b4dcf652010cf6c0c7 (patch)
tree00155b25d10d3ec444a19950a042c38047fe2cae
parent44719efd462686ec05cde66dd02a14ab6138a26b (diff)
downloadaur-da7bfd3e156e8ef8e08ac3b4dcf652010cf6c0c7.tar.gz
Update to 4577 and fix missing string includes
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf2b4edd2718..57b1d4a9c52b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libpdfium-nojs
pkgdesc = Open-source PDF rendering engine.
- pkgver = 4389.r1.157601b9b9
+ pkgver = 4577.r0.60a7195a9b
pkgrel = 1
url = https://pdfium.googlesource.com/pdfium/
arch = x86_64
@@ -24,4 +24,3 @@ pkgbase = libpdfium-nojs
md5sums = feb270967925a0844b1b9a9e15288eb3
pkgname = libpdfium-nojs
-
diff --git a/PKGBUILD b/PKGBUILD
index b0de601b48a9..8fbe32e066c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Felix Kauselmann <licorn@gmail.com>
pkgname=libpdfium-nojs
-pkgver=4389.r1.157601b9b9
+pkgver=4577.r0.60a7195a9b
pkgrel=1
pkgdesc="Open-source PDF rendering engine."
arch=('x86_64')
@@ -49,6 +49,12 @@ prepare() {
# git checkout "chromium/$(curl https://omahaproxy.appspot.com/linux?channel=beta | cut -d'.' -f 3)"
# git checkout "chromium/$(curl https://omahaproxy.appspot.com/linux?channel=dev | cut -d'.' -f 3)"
+ # Fix missing string headers for GCC + libstdcc compilation, but only for affected version
+ if [ `git rev-parse --abbrev-ref HEAD` == 'chromium/4577' ]
+ then
+ git cherry-pick -n 7a6289c
+ fi
+
# Extract build repo revision needed from DEPS file and do a checkout
cd "$srcdir/pdfium/build"
git checkout $(awk '/build_revision/ {print substr($2,2,40)}' $srcdir/pdfium/DEPS) -q