summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2023-05-12 02:06:27 +0200
committerChristopher Arndt2023-05-12 02:06:27 +0200
commit7f862a73133576c8d5c1016cbd3f620b08c20e11 (patch)
treef4ea931dfba5141feb708ecb558c2e1d4482c4e4
parent132f6a84ff6f837a08dbfd8f1c55e83feabe521e (diff)
downloadaur-7f862a73133576c8d5c1016cbd3f620b08c20e11.tar.gz
Update to upstream version 1.36.0
Split docs into -docs package Remove obsolete meson.build patching Add check function
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD55
2 files changed, 32 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a37ba8701f34..9ae777fd7927 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = libpeas-lua51
pkgdesc = A GObject plugin library (with Lua 5.1 support)
- pkgver = 1.30.0
+ pkgver = 1.36.0
pkgrel = 1
url = https://wiki.gnome.org/Projects/Libpeas
arch = x86_64
license = LGPL2.1
+ makedepends = gi-docgen
makedepends = gjs
makedepends = glade
makedepends = gobject-introspection
@@ -21,8 +22,7 @@ pkgbase = libpeas-lua51
optdepends = python-gobject: Python loader
provides = libpeas
conflicts = libpeas
- source = https://download.gnome.org/sources/libpeas/1.30/libpeas-1.30.0.tar.xz
- sha256sums = 0bf5562e9bfc0382a9dcb81f64340787542568762a3a367d9d90f6185898b9a3
+ source = https://download.gnome.org/sources/libpeas/1.36/libpeas-1.36.0.tar.xz
+ sha256sums = 297cb9c2cccd8e8617623d1a3e8415b4530b8e5a893e3527bbfd1edd13237b4c
pkgname = libpeas-lua51
-
diff --git a/PKGBUILD b/PKGBUILD
index 4f354293276e..e985e4e3b949 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,50 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
-_basename=libpeas
-_repo='https://gitlab.gnome.org/GNOME/libpeas'
-pkgname="${_basename}-lua51"
-pkgver=1.30.0
+_name=libpeas
+pkgbase=$_name-lua51
+pkgname=($_name-lua51 $_name-lua51-docs)
+pkgver=1.36.0
pkgrel=1
pkgdesc='A GObject plugin library (with Lua 5.1 support)'
-arch=('x86_64')
+arch=(x86_64)
+# Repo: https://gitlab.gnome.org/GNOME/libpeas
url='https://wiki.gnome.org/Projects/Libpeas'
-provides=('libpeas')
-conflicts=('libpeas')
-license=('LGPL2.1')
+provides=($_name)
+conflicts=($_name)
+license=(LGPL2.1)
depends=(gtk3 hicolor-icon-theme gobject-introspection)
-makedepends=(gjs glade gobject-introspection gtk-doc intltool lua51-lgi meson python-gobject vala)
+makedepends=(gi-docgen gjs glade gobject-introspection gtk-doc intltool lua51-lgi meson python-gobject vala)
optdepends=(
'lua51-lgi: Lua 5.1 loader'
'python-gobject: Python loader'
)
-source=(https://download.gnome.org/sources/$_basename/${pkgver:0:4}/$_basename-${pkgver}.tar.xz)
-sha256sums=('0bf5562e9bfc0382a9dcb81f64340787542568762a3a367d9d90f6185898b9a3')
-
-
-prepare() {
- cd "${srcdir}/${_basename}-${pkgver}"
-
- # Ugly workaround to fix lua51 and circumvent broken lua-lgi dependency detection
- local lua_lgi_ver=$(lua5.1 -e 'print(require("lgi")._VERSION)')
- sed -i \
- -e "s|'lua5\.1'|'lua51'|" \
- -e "s|^lua51_lgi_dep = .*$|lua51_lgi_dep = declare_dependency(version: '${lua_lgi_ver}')|" \
- meson.build
-}
+source=("https://download.gnome.org/sources/$_name/${pkgver:0:4}/$_name-$pkgver.tar.xz")
+sha256sums=('297cb9c2cccd8e8617623d1a3e8415b4530b8e5a893e3527bbfd1edd13237b4c')
build() {
- cd "${srcdir}/${_basename}-${pkgver}"
-
+ cd $_name-$pkgver
rm -rf build
arch-meson . build -D vapi=true -D gtk_doc=true -D lua51=true
ninja -C build
}
-package() {
- cd "${srcdir}/${_basename}-${pkgver}"
+check() {
+ cd $_name-$pkgver
+ meson test -C build
+}
+package_libpeas-lua51 () {
+ cd $_name-$pkgver
DESTDIR="$pkgdir" meson install -C build
+ mkdir -p "$srcdir"/doc
+ mv "$pkgdir"/usr/share/doc "$srcdir"/doc
+}
+
+package_libpeas-lua51-docs() {
+ pkgdesc+=" (documentation)"
+ depends=()
+
+ mv "$srcdir"/doc/* "$pkgdir"/usr/share
}
# vim:set ts=2 sw=2 et: