summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaryl Chng2017-01-10 13:17:23 +0800
committerJaryl Chng2017-01-10 13:17:23 +0800
commit8324ea1ac76fc6b45099f9557610cb713e41934a (patch)
tree18cb106007d567f977f6848c65662f57f609fd42
downloadaur-8324ea1ac76fc6b45099f9557610cb713e41934a.tar.gz
20161215.56cdada
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c56efec2a471
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libpff-git
+ pkgdesc = Library to access the Personal Folder File (PFF) and the Offline Folder File (OFF) format
+ pkgver = 20161215.56cdada
+ pkgrel = 1
+ url = https://github.com/libyal/libpff
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ provides = libpff-git
+ conflicts = libpff
+ source = git+https://github.com/libyal/libpff.git
+ sha1sums = SKIP
+
+pkgname = libpff-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f0ac1035adc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Jaryl Chng <mrciku@gmail.com>
+pkgname=libpff-git
+pkgver=20161215.56cdada
+pkgrel=1
+pkgdesc='Library to access the Personal Folder File (PFF) and the Offline Folder File (OFF) format'
+arch=('i686' 'x86_64')
+url='https://github.com/libyal/libpff'
+license=('LGPL')
+provides=('libpff-git')
+conflicts=('libpff')
+groups=()
+depends=()
+makedepends=('git')
+optdepends=()
+options=()
+source=('git+https://github.com/libyal/libpff.git')
+sha1sums=('SKIP')
+
+_gitname="libpff"
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+build() {
+ cd "$_gitname"
+
+ ./synclibs.sh
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc
+
+ make
+}
+
+package() {
+ cd "$_gitname"
+ make DESTDIR="$pkgdir/" install
+} \ No newline at end of file