summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-08-31 22:42:44 +0200
committerhaawda2019-08-31 22:42:44 +0200
commit3a304e163b39f3205d497c23893a103fbd7b61a8 (patch)
tree29e3b8fe1bb453131903a6fc9481caa9916d87bb
parent77719ec2b4b66f0e01284ecb5a337a1ee52c7e5f (diff)
downloadaur-3a304e163b39f3205d497c23893a103fbd7b61a8.tar.gz
adopted and updated
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 14 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04aa2d667203..e396086bbc09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = libphidget
pkgdesc = user-space access library for the Phidget devices
- pkgver = 2.1.8
- pkgrel = 2
+ pkgver = 2.1.9.20190409
+ pkgrel = 1
arch = x86_64
license = GPL
makedepends = libusb
depends = libusb
source = https://www.phidgets.com/downloads/libraries/libphidget.tar.gz
- sha256sums = 7393273fdefbb6cfb67f1a69fd2f140e0c0e396e9b7350400195cedbf1d4ea52
+ sha256sums = 0e789912700228808519cf5c41e19f9b761da635c6bb676b147897936b23851f
pkgname = libphidget
diff --git a/PKGBUILD b/PKGBUILD
index ce566e5609b9..2c0dfc7f6594 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,25 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=libphidget
-pkgver=2.1.8
-pkgdate=20151217
-pkgrel=2
+pkgver=2.1.9.20190409
+pkgrel=1
pkgdesc="user-space access library for the Phidget devices"
arch=('x86_64')
license=('GPL')
depends=('libusb')
makedepends=('libusb')
-source=(
- 'https://www.phidgets.com/downloads/libraries/libphidget.tar.gz'
-)
-sha256sums=(
- '7393273fdefbb6cfb67f1a69fd2f140e0c0e396e9b7350400195cedbf1d4ea52'
-)
+source=('https://www.phidgets.com/downloads/libraries/libphidget.tar.gz')
+sha256sums=('0e789912700228808519cf5c41e19f9b761da635c6bb676b147897936b23851f')
build() {
- cd $srcdir/$pkgname-$pkgver.$pkgdate
+ cd $pkgname-$pkgver
./configure --prefix=/usr
+ make
}
package() {
- cd $srcdir/$pkgname-$pkgver.$pkgdate
+ cd $pkgname-$pkgver
make DESTDIR="$pkgdir/" install
-
- install -d "${pkgdir}/usr/lib/udev/rules.d"
- install "udev/99-phidgets.rules" "${pkgdir}/usr/lib/udev/rules.d"
+ install -d "$pkgdir"/usr/lib/udev/rules.d
+ install "udev/99-phidgets.rules" "$pkgdir"/usr/lib/udev/rules.d
}