summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlav Frengstad2017-06-22 14:36:08 +0200
committerOlav Frengstad2017-06-22 14:36:08 +0200
commitd96af12a2cd3f330311daf2901d91460682ecf83 (patch)
treee9a1b5d7bca58dbf42104ca821128319fc36b150
parente7356f2bae3622bddfc292f58a725ad41b704e65 (diff)
downloadaur-d96af12a2cd3f330311daf2901d91460682ecf83.tar.gz
Install udev rules
Add rules to allow non-root users to access the device
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7cc7bcc92269..ce566e5609b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=libphidget
pkgver=2.1.8
pkgdate=20151217
-pkgrel=1
+pkgrel=2
pkgdesc="user-space access library for the Phidget devices"
arch=('x86_64')
license=('GPL')
@@ -22,4 +22,7 @@ build() {
package() {
cd $srcdir/$pkgname-$pkgver.$pkgdate
make DESTDIR="$pkgdir/" install
+
+ install -d "${pkgdir}/usr/lib/udev/rules.d"
+ install "udev/99-phidgets.rules" "${pkgdir}/usr/lib/udev/rules.d"
}