summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-03-03 05:55:54 +0100
committerhaawda2018-03-03 05:55:54 +0100
commit1ec5df5317874b6ad7b63d4b5f8ea662f8c42edf (patch)
treed9b3f06d55dc1d8ea9d38267a70ed485db1fe7a1
downloadaur-1ec5df5317874b6ad7b63d4b5f8ea662f8c42edf.tar.gz
initial upload
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d89224a1b0ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libphidget22
+ pkgdesc = user-space access library for the Phidget devices
+ pkgver = 1.0.0.20180216
+ pkgrel = 1
+ arch = x86_64
+ license = GPL
+ depends = libusb
+ provides = libphidget
+ conflicts = libphidget
+ source = https://www.phidgets.com/downloads/phidget22/libraries/linux/libphidget22/libphidget22-1.0.0.20180216.tar.gz
+ sha256sums = 78fbb1e2c7c3c6b78c1b66372ab0540f7f6fcbe21cbb7f9bb41ae0b2dfdbf29d
+
+pkgname = libphidget22
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a2cab2406d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=libphidget22
+pkgver=1.0.0.20180216
+pkgrel=1
+pkgdesc="user-space access library for the Phidget devices"
+conflicts=('libphidget')
+provides=('libphidget')
+arch=('x86_64')
+license=('GPL')
+depends=('libusb')
+source=("https://www.phidgets.com/downloads/${pkgname#lib}/libraries/linux/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('78fbb1e2c7c3c6b78c1b66372ab0540f7f6fcbe21cbb7f9bb41ae0b2dfdbf29d')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir/" install
+}