summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2015-04-23 22:39:50 -0500
committerDoug Newgard2015-04-23 22:39:50 -0500
commita09873587a6210e535d384d043536ab67887d98d (patch)
tree0a4638f6c1e46a5be44b45980eba4e00133e837f
downloadaur-a09873587a6210e535d384d043536ab67887d98d.tar.gz
Inherited from sergio.correia
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ed6b36ef0c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libphutil-git
+ pkgdesc = Library system which organizes PHP classes and functions into modules
+ pkgver = conduit.5.464.g54dbec7
+ pkgrel = 1
+ url = http://phabricator.com
+ arch = any
+ license = Apache
+ makedepends = git
+ depends = php
+ provides = libphutil
+ source = git://github.com/facebook/libphutil.git
+ sha256sums = SKIP
+
+pkgname = libphutil-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..71a9d16c2b38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*~
+*/
+*.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fee5fcdcb11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sergio Correia <sergio@correia.cc>
+# Contributor: Nicolas Vivet <nizzox@gmail.com>
+
+pkgname=libphutil-git
+_pkgname=libphutil
+pkgver=conduit.5.464.g54dbec7
+pkgrel=1
+pkgdesc='Library system which organizes PHP classes and functions into modules'
+arch=('any')
+url="http://phabricator.com"
+license=('Apache')
+depends=('php')
+makedepends=('git')
+provides=('libphutil')
+source=('git://github.com/facebook/libphutil.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --always | sed 's|-|.|g' # Use the tag of the last commit
+}
+
+package() {
+ mkdir -p "${pkgdir}"/usr/share/php/"${_pkgname}"
+ # do not copy hidden directories
+ cp -a "${srcdir}"/"${_pkgname}"/* "${pkgdir}"/usr/share/php/"${_pkgname}"/
+}
+
+# vim:set ts=2 sw=2 et: