summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Wilper2021-05-05 21:40:02 +0200
committerSimon Wilper2021-05-05 21:40:02 +0200
commit8102ade02b895109ff317d6fbb7692428446e3a7 (patch)
tree1a7e75664b4eb5acd4358c8fdb53ddadb27193fa
parent974e793e843992adbd8895962c6a981f6c40f523 (diff)
downloadaur-8102ade02b895109ff317d6fbb7692428446e3a7.tar.gz
version 2.3.6
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 127e0fa6bc0a..b5938e7e2241 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = libplctag
- pkgdesc = This library provides a portable and simple API for accessing Allen-Bradley PLC data over Ethernet
- pkgver = 2.0.20
+ pkgdesc = API for accessing Allen-Bradley and Modbus PLC data over Ethernet
+ pkgver = 2.3.6
pkgrel = 1
url = https://github.com/kyle-github/libplctag
arch = x86_64
license = GPL
makedepends = cmake
- source = https://github.com/kyle-github/libplctag/archive/v2.0.20.tar.gz
- sha512sums = ce7769512e28cbe647bcfedb7f80f642c42a774db7465c8a24c4263fa4190d4eee18dfa63edd446890e4294ffae4785a4eff2182cd90726dcf9ed234543c87f0
+ source = https://github.com/kyle-github/libplctag/archive/v2.3.6.tar.gz
+ sha512sums = a2ef3e46f48e7304ac9b7e0d90891ebe97956b0a43105b94c5a2df60b42f2e550062ce3eabd771f74c9ec3eb2800b50d588dd1da551a537593996505de914b7e
pkgname = libplctag
diff --git a/PKGBUILD b/PKGBUILD
index 3fd4af34351b..57e08f806fc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Simon Wilper <sxw@chronowerks.de>
pkgname=libplctag
-pkgver=2.0.20
+pkgver=2.3.6
pkgrel=1
-pkgdesc="This library provides a portable and simple API for accessing Allen-Bradley PLC data over Ethernet"
+pkgdesc='API for accessing Allen-Bradley and Modbus PLC data over Ethernet'
arch=('x86_64')
url="https://github.com/kyle-github/$pkgname"
license=('GPL')
@@ -11,17 +11,18 @@ makedepends=('cmake')
source=("$url/archive/v$pkgver.tar.gz")
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
mkdir build && cd build
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr ".."
+
make
}
package() {
- cd "$pkgname-$pkgver/build"
+ cd "$pkgname-$pkgver/build"
make DESTDIR="$pkgdir/" install
}
-sha512sums=('ce7769512e28cbe647bcfedb7f80f642c42a774db7465c8a24c4263fa4190d4eee18dfa63edd446890e4294ffae4785a4eff2182cd90726dcf9ed234543c87f0')
+sha512sums=('a2ef3e46f48e7304ac9b7e0d90891ebe97956b0a43105b94c5a2df60b42f2e550062ce3eabd771f74c9ec3eb2800b50d588dd1da551a537593996505de914b7e')