summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-22 23:04:05 -0500
committerVincent Grande2021-01-22 23:04:05 -0500
commit932c3efd5541ca16a69546057099e280a724a790 (patch)
tree91beb597e76f8dc2324cec649129951aece62b8b
downloadaur-932c3efd5541ca16a69546057099e280a724a790.tar.gz
initial upload
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD60
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69ee84197048
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libpng12-git
+ pkgdesc = A collection of routines used to create PNG format graphics files
+ pkgver = 1.2.59
+ pkgrel = 1
+ url = http://www.libpng.org/pub/png/libpng.html
+ arch = x86_64
+ license = custom
+ depends = glibc
+ depends = zlib
+ provides = libpng12
+ conflicts = libpng12
+ source = git://git.code.sf.net/p/libpng/code#branch=libpng12
+ source = https://sourceforge.net/projects/libpng-apng/files/libpng12/1.2.59/libpng-1.2.59-apng.patch.gz
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = libpng12-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a679d6a629df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Arthur Zamarin <arthurzam@gmail.com>
+# Contributor: trya <tryagainprod@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: dorphell <dorphell@archlinux.org>
+# Contributor: Travis Willard <travis@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+
+pkgname=libpng12-git
+pkgver=1.2.59
+pkgrel=1
+pkgdesc='A collection of routines used to create PNG format graphics files'
+arch=('x86_64')
+url='http://www.libpng.org/pub/png/libpng.html'
+license=('custom')
+depends=('glibc' 'zlib')
+provides=(libpng12)
+conflicts=(libpng12)
+source=(git://git.code.sf.net/p/libpng/code#branch=libpng12
+ "https://sourceforge.net/projects/libpng-apng/files/libpng12/${pkgver}/libpng-${pkgver}-apng.patch.gz")
+#validpgpkeys=('8048643BA2C840F4F92A195FF54984BFA16C640F') # Glenn Randers-Pehrson
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd libpng
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd libpng
+
+ patch -Np1 -i ../libpng-${pkgver}-apng.patch
+
+ libtoolize --force --copy
+ aclocal
+ autoconf
+ automake --add-missing
+}
+
+build() {
+ cd libpng
+
+ ./autogen.sh
+ ./configure \
+ --prefix='/usr'
+ make
+}
+
+package() {
+ cd libpng
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/{bin,include/*.h,lib/{libpng.{a,so},pkgconfig},share}
+
+ install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/libpng12/
+}
+
+# vim: ts=2 sw=2 et: