summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-28 22:06:48 +0200
committerChristian Hesse2015-06-28 22:06:48 +0200
commit2fb3e71d79732f82041178f4871922ddab18c4a2 (patch)
tree1e09bfb1e30a2f517a498fb1964216c9ab2c9f14
downloadaur-2fb3e71d79732f82041178f4871922ddab18c4a2.tar.gz
initial import of libpng15 1.5.22-2
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..323a8e2cecb0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libpng15
+ pkgdesc = A collection of routines used to create PNG format graphics files (1.5 branch)
+ pkgver = 1.5.22
+ pkgrel = 2
+ url = http://www.libpng.org/pub/png/libpng.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = zlib
+ conflicts = libpng<1.6
+ options = !libtool
+ source = http://downloads.sourceforge.net/sourceforge/libpng/libpng-1.5.22.tar.xz
+ source = http://downloads.sourceforge.net/sourceforge/libpng/libpng-1.5.22.tar.xz.asc
+ source = http://downloads.sourceforge.net/sourceforge/libpng-apng/libpng-1.5.22-apng.patch.gz
+ sha256sums = 29bff0fb911236654dc3dbe6aed9c6f557b1ceb6aa28bed13089cf2b85d0af76
+ sha256sums = SKIP
+ sha256sums = c7a624b53cc8d8a50602f5704682ceae8b6918bb703df5ad113ded84a9597e01
+
+pkgname = libpng15
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cedef2b88f64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=libpng15
+pkgver=1.5.22
+pkgrel=2
+pkgdesc="A collection of routines used to create PNG format graphics files (1.5 branch)"
+arch=('i686' 'x86_64')
+url="http://www.libpng.org/pub/png/libpng.html"
+license=('custom')
+depends=('zlib')
+conflicts=('libpng<1.6')
+options=('!libtool')
+source=("http://downloads.sourceforge.net/sourceforge/libpng/libpng-${pkgver}.tar.xz"{,.asc}
+ "http://downloads.sourceforge.net/sourceforge/libpng-apng/libpng-${pkgver}-apng.patch.gz")
+validpgpkeys=('8048643BA2C840F4F92A195FF54984BFA16C640F')
+
+build() {
+ cd libpng-${pkgver}
+
+ # Add animated PNG (apng) support
+ # see http://sourceforge.net/projects/libpng-apng/
+ patch -p1 -i ../libpng-${pkgver}-apng.patch
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd libpng-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+
+ rm -rf "${pkgdir}/usr/"{bin,include,lib/{pkgconfig,libpng.so,libpng.a},share}
+}
+
+sha256sums=('29bff0fb911236654dc3dbe6aed9c6f557b1ceb6aa28bed13089cf2b85d0af76'
+ 'SKIP'
+ 'c7a624b53cc8d8a50602f5704682ceae8b6918bb703df5ad113ded84a9597e01')