summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaimar Bühmann2015-07-13 22:55:22 +0200
committerRaimar Bühmann2015-07-13 22:55:22 +0200
commit5e291215c0027a56e4fe64b13b96a4becd156571 (patch)
tree4f8bfb591c48064e5dee2e7305c11c25977eb87d
parent82157ecc1a0451d959812ff72f0d569e9380eb00 (diff)
downloadaur-5e291215c0027a56e4fe64b13b96a4becd156571.tar.gz
update to 1.6.0
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--Makefile.patch2
-rw-r--r--PKGBUILD13
-rw-r--r--RegularExpression.h.patch18
-rw-r--r--pcre_internal.h.patch5
6 files changed, 32 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dda9076e0947..2f80d6757e6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libpoco-basic
pkgdesc = C++ class libraries for network-centric, portable applications, basic edition
- pkgver = 1.4.7
+ pkgver = 1.6.0
pkgrel = 1
url = http://www.pocoproject.org
arch = i686
@@ -13,12 +13,10 @@ pkgbase = libpoco-basic
conflicts = poco
conflicts = poco-devel
conflicts = poco-git
- source = http://www.pocoproject.org/releases/poco-1.4.7/poco-1.4.7.tar.gz
- source = Makefile.patch
- source = pcre_internal.h.patch
- sha256sums = ec3f726d9a46273b407f86fac2fed55d4035039780ba9ba7b4e714ad52189d22
- sha256sums = cd8d4d6780d31ec7d1f935f9342c17fe04144c33934b12509cf942ff7fa44c0f
- sha256sums = 874d9f29e46e43afad0a3c24376615349d1a7be2d19c4b1712efe600bcc665c0
+ source = http://www.pocoproject.org/releases/poco-1.6.0/poco-1.6.0.tar.gz
+ source = RegularExpression.h.patch
+ sha256sums = 8e745271d57db8d544d5c8e37b3b7db01d7934e0257a41af0b8da9ee8b1554ee
+ sha256sums = af43ef3b60f4bfba49071d6393fa22311d65277ff05d335c3fe29283b3c04222
pkgname = libpoco-basic
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b298c10ef0f8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+libpoco-basic-*.pkg.tar.xz
+poco-*.tar.gz
diff --git a/Makefile.patch b/Makefile.patch
deleted file mode 100644
index 4bfdb72d9d64..000000000000
--- a/Makefile.patch
+++ /dev/null
@@ -1,2 +0,0 @@
-46a47
-> objects += $(pcre_utf8_objects)
diff --git a/PKGBUILD b/PKGBUILD
index 7c113e18bb45..9cfd74c7df90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# https://aur.archlinux.org/packages/poco/
pkgname=libpoco-basic
-_pkgver_main=1.4.7
+_pkgver_main=1.6.0
pkgver=${_pkgver_main}
pkgrel=1
pkgdesc="C++ class libraries for network-centric, portable applications, basic edition"
@@ -15,17 +15,14 @@ conflicts=('poco' 'poco-devel' 'poco-git')
makedepends=('gcc' 'make')
source=(
${url}/releases/poco-${_pkgver_main}/poco-${pkgver}.tar.gz
- Makefile.patch
- pcre_internal.h.patch
+ RegularExpression.h.patch
)
-sha256sums=('ec3f726d9a46273b407f86fac2fed55d4035039780ba9ba7b4e714ad52189d22'
- 'cd8d4d6780d31ec7d1f935f9342c17fe04144c33934b12509cf942ff7fa44c0f'
- '874d9f29e46e43afad0a3c24376615349d1a7be2d19c4b1712efe600bcc665c0')
+sha256sums=('8e745271d57db8d544d5c8e37b3b7db01d7934e0257a41af0b8da9ee8b1554ee'
+ 'af43ef3b60f4bfba49071d6393fa22311d65277ff05d335c3fe29283b3c04222')
prepare() {
# apply patch for static build
cd poco-$pkgver
- patch Foundation/Makefile < ../Makefile.patch
- patch Foundation/src/pcre_internal.h < ../pcre_internal.h.patch
+ patch Foundation/include/Poco/RegularExpression.h < ../RegularExpression.h.patch
}
build() {
diff --git a/RegularExpression.h.patch b/RegularExpression.h.patch
new file mode 100644
index 000000000000..fc0618742a86
--- /dev/null
+++ b/RegularExpression.h.patch
@@ -0,0 +1,18 @@
+30,39c30,35
+< //
+< // Copy these definitions from pcre.h
+< // to avoid pulling in the entire header file
+< //
+< extern "C"
+< {
+< struct real_pcre8_or_16; /* declaration; the definition is private */
+< typedef struct real_pcre8_or_16 pcre;
+< struct pcre_extra;
+< }
+---
+> #if defined(POCO_UNBUNDLED)
+> #include <pcre.h>
+> #else
+> #include "pcre_config.h"
+> #include "pcre.h"
+> #endif
diff --git a/pcre_internal.h.patch b/pcre_internal.h.patch
deleted file mode 100644
index 94d9da586219..000000000000
--- a/pcre_internal.h.patch
+++ /dev/null
@@ -1,5 +0,0 @@
-1155a1156,1159
-> #define _pcre_ucd_records _pcre_ucd_records_
-> #define _pcre_ucd_stage1 _pcre_ucd_stage1_
-> #define _pcre_ucd_stage2 _pcre_ucd_stage2_
-> #define _pcre_ucp_gentype _pcre_ucp_gentype_