summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominik S. Buse2018-12-05 14:19:27 +0100
committerDominik S. Buse2018-12-05 14:21:40 +0100
commit0625e5e43587399b79e01ca008b5356cb0d2124e (patch)
tree5eef8231f035acbc917083530f9b616d54926181
parentc3e9f5eea9b20c25fe519dd5810689d32d659322 (diff)
downloadaur-0625e5e43587399b79e01ca008b5356cb0d2124e.tar.gz
Remove -i flag from go build calls
`go build` should no longer use the -i flag with recent versions of go. Otherwise this could lead to errors if go is installed system-wide. For more info see [1]. [1] https://github.com/golang/go/issues/24674
-rw-r--r--PKGBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8699e3130fb4..73037556896a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -42,6 +42,7 @@ prepare() {
build() {
export GOPATH="${srcdir}/go"
cd "${GOPATH}/src/github.com/containers/${pkgbase}"
+ sed -i 's/$(GO) build -i/$(GO) build/' Makefile
make install.tools
make all