summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Orth2018-12-28 09:25:26 +0200
committerAlan Orth2018-12-28 09:25:26 +0200
commit0bbef98bb0b2b9bc70a34451bb40ac55f8bd7c3f (patch)
treeb1caa8f0731d93bc58aefd2b12318614c658224c
parent71a13b25fdd18860af3b99f2f72c5de42613de8a (diff)
downloadaur-0bbef98bb0b2b9bc70a34451bb40ac55f8bd7c3f.tar.gz
Bump package release version to 0.12.1.2-2
Moves libpod-networking into main libpod package. libpod-networking was an optional dependency when petris first created the libpod AUR package, but it was eventually changed to be a hard dependency. Now there is no point having it as a separate "package" and we can just move it into the main libpod package.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 10 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f00540ed4698..0522a5abe359 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libpod
pkgdesc = A library used to create container pods.
pkgver = 0.12.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/containers/libpod
arch = x86_64
license = Apache
@@ -21,7 +21,7 @@ pkgbase = libpod
pkgname = libpod
depends = cri-o
depends = device-mapper
- depends = libpod-networking
+ depends = iptables
depends = libseccomp
depends = runc
depends = ostree
@@ -29,7 +29,9 @@ pkgname = libpod
optdepends = libpod-docker: docker cli
optdepends = libpod-python: pypodman
provides = podman
+ provides = libpod-networking
conflicts = podman
+ conflicts = libpod-networking
pkgname = libpod-docker
pkgdesc = Use podman as a Docker CLI replacement.
@@ -37,12 +39,6 @@ pkgname = libpod-docker
provides = docker
conflicts = docker
-pkgname = libpod-networking
- pkgdesc = Networking configuration for libpod.
- depends = libpod
- depends = cni-plugins
- depends = iptables
-
pkgname = libpod-python
pkgdesc = CLI for podman written in python.
depends = libpod
diff --git a/PKGBUILD b/PKGBUILD
index 63d61b0a4f8e..52dbdf449aa2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,10 @@ pkgbase=libpod
pkgname=(
"libpod"
"libpod-docker"
- "libpod-networking"
"libpod-python"
)
pkgver=0.12.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="A library used to create container pods."
arch=("x86_64")
url="https://github.com/containers/libpod"
@@ -52,7 +51,7 @@ package_libpod() {
depends+=(
"cri-o"
"device-mapper"
- "libpod-networking"
+ "iptables"
"libseccomp"
"runc"
"ostree"
@@ -64,15 +63,18 @@ package_libpod() {
)
provides+=(
"podman"
+ # 2018-12-28: keep this for a few releases for packages that depend on it
+ "libpod-networking"
)
conflicts+=(
"podman"
+ "libpod-networking"
)
export GOPATH="${srcdir}/go"
cd "${GOPATH}/src/github.com/containers/${pkgbase}"
- make install.bin install.completions install.config install.man install.systemd DESTDIR="${pkgdir}" PREFIX="${pkgdir}/usr"
+ make install.bin install.cni install.completions install.config install.man install.systemd DESTDIR="${pkgdir}" PREFIX="${pkgdir}/usr"
# seccomp.json is provided by cri-o
rm "${pkgdir}/etc/crio/seccomp.json"
@@ -97,20 +99,6 @@ package_libpod-docker() {
make install.docker DESTDIR="${pkgdir}" PREFIX="${pkgdir}/usr"
}
-package_libpod-networking() {
- pkgdesc="Networking configuration for libpod."
- depends+=(
- "libpod"
- "cni-plugins"
- "iptables"
- )
-
- export GOPATH="${srcdir}/go"
- cd "${GOPATH}/src/github.com/containers/${pkgbase}"
-
- make install.cni DESTDIR="${pkgdir}" PREFIX="${pkgdir}/usr"
-}
-
package_libpod-python() {
pkgdesc="CLI for podman written in python."
depends+=(