summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Petris2018-10-16 18:13:44 -0400
committerRyan Petris2018-10-16 18:13:44 -0400
commit122b3f0dd063cc171d3b518dc26ec4fea01cfdca (patch)
tree407a41f773e6dd57fd33d5c5cce4c229f26e86f4
downloadaur-122b3f0dd063cc171d3b518dc26ec4fea01cfdca.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD52
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13bcf6239355
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = libpod
+ pkgdesc = Utility for running OCI-based containers.
+ pkgver = 0.10.1
+ pkgrel = 1
+ url = https://github.com/containers/libpod
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ makedepends = go-md2man
+ depends = python
+ depends = cri-o
+ depends = cni-plugins
+ depends = skopeo
+ depends = device-mapper
+ depends = libseccomp
+ depends = iptables
+ depends = runc
+ depends = ostree
+ conflicts = podman
+ source = https://github.com/containers/libpod/archive/v0.10.1.tar.gz
+ sha256sums = c456a6e5c89ae938607154a16ec07efeda5287351d2741b762c495e651189cf5
+
+pkgname = libpod
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4cfe445568f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Ryan Petris (ryan@petris.net)
+
+pkgname=libpod
+pkgver=0.10.1
+pkgrel=1
+pkgdesc="Utility for running OCI-based containers."
+arch=("x86_64")
+url="https://github.com/containers/libpod"
+license=("Apache")
+
+depends=(
+ "python"
+ "cri-o"
+ "cni-plugins"
+ "skopeo"
+ "device-mapper"
+ "libseccomp"
+ "iptables"
+ "runc"
+ "ostree"
+)
+
+makedepends=("go" "go-md2man")
+conflicts=("podman")
+source=("https://github.com/containers/libpod/archive/v${pkgver}.tar.gz")
+sha256sums=("c456a6e5c89ae938607154a16ec07efeda5287351d2741b762c495e651189cf5")
+
+prepare() {
+ export GOPATH="${srcdir}/go"
+ mkdir -p "${GOPATH}/src/github.com/containers"
+
+ sed -i "s/-ldflags '\$(LDFLAGS)'/-gccgoflags '\$(LDFLAGS)'/g" "${pkgname}-${pkgver}/Makefile"
+ sed -i "s/-ldflags '\$(LDFLAGS_PODMAN)'/-gccgoflags '\$(LDFLAGS)' -ldflags '\$(LDFLAGS_PODMAN)'/g" "${pkgname}-${pkgver}/Makefile"
+ sed -i "s/LDFLAGS_PODMAN ?= \$(LDFLAGS)/LDFLAGS_PODMAN ?=/g" "${pkgname}-${pkgver}/Makefile"
+
+ mv "${pkgname}-${pkgver}" "${GOPATH}/src/github.com/containers/${pkgname}"
+}
+
+build() {
+ export GOPATH="${srcdir}/go"
+ cd "${GOPATH}/src/github.com/containers/${pkgname}"
+
+ make install.tools
+ make all
+}
+
+package() {
+ export GOPATH="${srcdir}/go"
+ cd "${GOPATH}/src/github.com/containers/${pkgname}"
+
+ make install DESTDIR="${pkgdir}" PREFIX="${pkgdir}/usr"
+}