summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Petris2018-10-22 15:50:39 -0400
committerRyan Petris2018-10-22 15:50:39 -0400
commit4e77847f6f55d0d51fea176192c0df497056117f (patch)
tree497dad35e606f49ea6d5c82e45fef959809f4954
parentda70cd149dc689b637db78c453a31924096da156 (diff)
downloadaur-4e77847f6f55d0d51fea176192c0df497056117f.tar.gz
Move libpod-networking and skopeo from optdepends to depends
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37c7cae97e59..6ca926134f09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libpod
pkgdesc = A library used to create container pods.
pkgver = 0.10.1.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/containers/libpod
arch = x86_64
license = Apache
@@ -21,13 +21,13 @@ pkgbase = libpod
pkgname = libpod
depends = cri-o
depends = device-mapper
+ depends = libpod-networking
depends = libseccomp
depends = runc
depends = ostree
+ depends = skopeo
optdepends = libpod-docker: docker cli
- optdepends = libpod-networking: enable networking
optdepends = libpod-python: pypodman
- optdepends = skopeo: default registry configuration
provides = podman
conflicts = podman
diff --git a/PKGBUILD b/PKGBUILD
index 2da2738c1c36..31c79a5d1a7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgname=(
"libpod-python"
)
pkgver=0.10.1.3
-pkgrel=2
+pkgrel=3
pkgdesc="A library used to create container pods."
arch=("x86_64")
url="https://github.com/containers/libpod"
@@ -51,15 +51,15 @@ package_libpod() {
depends+=(
"cri-o"
"device-mapper"
+ "libpod-networking"
"libseccomp"
"runc"
"ostree"
+ "skopeo"
)
optdepends+=(
"libpod-docker: docker cli"
- "libpod-networking: enable networking"
"libpod-python: pypodman"
- "skopeo: default registry configuration"
)
provides+=(
"podman"