summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarshit Shah2018-01-26 16:47:46 +0100
committerDarshit Shah2018-01-26 16:47:46 +0100
commitd622d67f8eec5bd1a821654e7bac3c633c7f72d2 (patch)
treeb3bf4636888eded608534af81ccf9f6ee4581517
downloadaur-d622d67f8eec5bd1a821654e7bac3c633c7f72d2.tar.gz
Add initial PKGBUILD
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD52
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..685938960f3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libpsl-git
+ pkgdesc = Public Suffix List library
+ pkgver = libpsl.0.19.1.r5.g27614b6
+ pkgrel = 1
+ url = https://github.com/rockdaboot/libpsl
+ arch = x86_64
+ license = MIT
+ makedepends = libxslt
+ makedepends = python
+ makedepends = publicsuffix-list
+ makedepends = gtk-doc
+ depends = libidn2
+ depends = libunistring
+ source = git+https://github.com/rockdaboot/libpsl.git
+ sha512sums = SKIP
+
+pkgname = libpsl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac76e9611abb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Darshit Shah <darnir [at] gnu [dot] org>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
+
+_pkgname=libpsl
+pkgname=$_pkgname-git
+pkgver=libpsl.0.19.1.r5.g27614b6
+pkgrel=1
+pkgdesc='Public Suffix List library'
+url='https://github.com/rockdaboot/libpsl'
+arch=('x86_64')
+license=('MIT')
+depends=('libidn2' 'libunistring')
+makedepends=('libxslt' 'python' 'publicsuffix-list' 'gtk-doc')
+source=(git+https://github.com/rockdaboot/${_pkgname}.git)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd ${_pkgname}
+ ./autogen.sh
+}
+
+build() {
+ cd ${_pkgname}
+ ./configure \
+ --prefix=/usr \
+ --disable-static \
+ --disable-dependency-tracking \
+ --enable-man \
+ --enable-gtk-doc \
+ --enable-{builtin,runtime}=libidn2 \
+ --with-psl-file=/usr/share/publicsuffix/effective_tld_names.dat \
+ --with-psl-testfile=/usr/share/publicsuffix/test_psl.txt
+ LC_CTYPE=en_US.UTF-8 make
+}
+
+check() {
+ cd ${_pkgname}
+ make check
+}
+
+package() {
+ cd ${_pkgname}
+ make DESTDIR="${pkgdir}" install
+ install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
+# vim: ts=2 sw=2 et: