summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 06:45:44 -0600
committerBrian Bidulock2015-06-10 06:45:44 -0600
commit60c6e2893899d7af3174f7e2461db7b76532c3cb (patch)
tree57ddd6e92c9ca879db1f6106244d2149a22f4be2
downloadaur-60c6e2893899d7af3174f7e2461db7b76532c3cb.tar.gz
initial version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f38671ec820
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libpthread-stubs
+ pkgdesc = This library provides weak aliases for pthread functions not provided in libc or otherwise available by default.
+ pkgver = 0.3
+ pkgrel = 6
+ url = http://xcb.freedesktop.org/dist/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ source = http://xcb.freedesktop.org/dist/libpthread-stubs-0.3.tar.gz
+ md5sums = a09d928c4af54fe5436002345ef71138
+ sha256sums = 3031f466cf0b06de6b3ccbf2019d15c4fcf75229b7d226a711bc1885b3a82cde
+
+pkgname = libpthread-stubs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef3fe6340d64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Robert Wiklund <robert@wikro.org>
+# Contributor: carstene1ns <arch carsten-teibes de>
+
+pkgname=libpthread-stubs
+pkgver=0.3
+pkgrel=6
+pkgdesc="This library provides weak aliases for pthread functions not provided in libc or otherwise available by default."
+arch=('i686' 'x86_64')
+url="http://xcb.freedesktop.org/dist/"
+license=('MIT')
+source=("http://xcb.freedesktop.org/dist/${pkgname}-${pkgver}.tar.gz")
+md5sums=('a09d928c4af54fe5436002345ef71138')
+sha256sums=('3031f466cf0b06de6b3ccbf2019d15c4fcf75229b7d226a711bc1885b3a82cde')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}/" install
+}
+
+# vim:set ts=2 sw=2 et: