summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey D2014-03-07 13:11:23 +0400
committerAlexey D2015-07-05 11:09:28 +0300
commita9c69b06d7ef48459b9bc873cef7d1e2b3a7fe1b (patch)
tree0f4856c935f67af73216fb0e1c19832eb4f3a6de
parentac2247480b1863d0cf3670f0d0fba81af5b28efd (diff)
downloadaur-a9c69b06d7ef48459b9bc873cef7d1e2b3a7fe1b.tar.gz
version 5.0-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b86d1b10f7..dc35e65d0c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libpulse-nosystemd
pkgdesc = Client library for PulseAudio
- pkgver = 6.0
+ pkgver = 5.0
pkgrel = 1
url = http://www.freedesktop.org/wiki/Software/PulseAudio
arch = i686
@@ -11,10 +11,10 @@ pkgbase = libpulse-nosystemd
makedepends = attr
makedepends = libxtst
makedepends = libsm
- makedepends = libsndfile
+ makedepends = libsamplerate
makedepends = libtool
makedepends = rtkit
- makedepends = speexdsp
+ makedepends = speex
makedepends = tdb
makedepends = dbus
makedepends = avahi
@@ -24,7 +24,7 @@ pkgbase = libpulse-nosystemd
makedepends = intltool
makedepends = jack2-dbus
makedepends = sbc
- makedepends = lirc
+ makedepends = lirc-utils
makedepends = openssl
makedepends = xenstore
makedepends = fftw
@@ -33,6 +33,7 @@ pkgbase = libpulse-nosystemd
makedepends = gtk3
makedepends = webrtc-audio-processing
makedepends = check
+ makedepends = git
depends = dbus
depends = libasyncns
depends = libcap
@@ -42,13 +43,13 @@ pkgbase = libpulse-nosystemd
depends = json-c
optdepends = alsa-plugins: ALSA support
optdepends = avahi: zeroconf support
- provides = libpulse=6.0
+ provides = libpulse=5.0
conflicts = libpulse
replaces = libpulse
options = !emptydirs
backup = etc/pulse/client.conf
- source = http://freedesktop.org/software/pulseaudio/releases/pulseaudio-6.0.tar.xz
- sha256sums = b50640e0b80b1607600accfad2e45aabb79d379bf6354c9671efa2065477f6f6
+ source = http://freedesktop.org/software/pulseaudio/releases/pulseaudio-5.0.tar.xz
+ sha256sums = 99c13a8b1249ddbd724f195579df79484e9af6418cecf6a15f003a7f36caf939
pkgname = libpulse-nosystemd
diff --git a/PKGBUILD b/PKGBUILD
index f2b80bb6058..24e6a27a5f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,16 +7,16 @@
pkgname=libpulse-nosystemd
_pkgbase=pulseaudio
pkgdesc="Client library for PulseAudio"
-pkgver=6.0
+pkgver=5.0
pkgrel=1
arch=(i686 x86_64)
url="http://www.freedesktop.org/wiki/Software/PulseAudio"
license=(LGPL)
depends=(dbus libasyncns libcap libxtst libsm libsndfile json-c)
-makedepends=(libasyncns libcap attr libxtst libsm libsndfile libtool rtkit
- speexdsp tdb dbus avahi bluez bluez-libs gconf intltool jack2-dbus sbc
- lirc openssl xenstore fftw orc json-c gtk3 webrtc-audio-processing
- check)
+makedepends=(libasyncns libcap attr libxtst libsm libsamplerate libtool rtkit
+ speex tdb dbus avahi bluez bluez-libs gconf intltool jack2-dbus sbc
+ lirc-utils openssl xenstore fftw orc json-c gtk3 webrtc-audio-processing
+ check git)
optdepends=('alsa-plugins: ALSA support'
'avahi: zeroconf support')
provides=("libpulse=${pkgver}")
@@ -25,7 +25,7 @@ replaces=('libpulse')
backup=(etc/pulse/client.conf)
options=(!emptydirs)
source=(http://freedesktop.org/software/$_pkgbase/releases/$_pkgbase-$pkgver.tar.xz)
-sha256sums=('b50640e0b80b1607600accfad2e45aabb79d379bf6354c9671efa2065477f6f6')
+sha256sums=('99c13a8b1249ddbd724f195579df79484e9af6418cecf6a15f003a7f36caf939')
prepare() {
cd $_pkgbase-$pkgver
@@ -42,12 +42,9 @@ build() {
--with-database=tdb \
--disable-tcpwrap \
--disable-bluez4 \
- --disable-samplerate \
--disable-rpath \
--disable-default-build-tests \
- --disable-systemd-daemon \
- --disable-systemd-login \
- --disable-systemd-journal
+ --disable-systemd
# fight unused direct deps
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool