summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSýlvan Heuser2019-03-10 16:14:18 +0100
committerSýlvan Heuser2019-03-10 16:14:18 +0100
commite36055b021eaabea89d7f764c6f42f3b8ceaa7df (patch)
treed47852b31446c673099d1504fbcbbbfd7f8ce278
parent0bf667bdabfe4d5d923a6c2713f743ef23aa6b0c (diff)
downloadaur-e36055b021eaabea89d7f764c6f42f3b8ceaa7df.tar.gz
libpurple-lurch-git: fix submodule issue
The upstream `.gitmodules` file specifies relative paths that can be correctly resolved in a direct clone of the upstream GitHub repository, but not in the local filesystem clone that makepkg does. Thanks to eskimod <https://aur.archlinux.org/account/eskimod> for an elegant solution. The `submodule sync` is skipped, as it should happen during the `init` anyway and might overwrite local changes someone might want to add.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d19ab191d451..873bbf03007c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu Mar 2 21:32:41 UTC 2017
pkgbase = libpurple-lurch-git
pkgdesc = Plugin for libpurple (Pidgin, Adium, etc) implementing OMEMO (using axolotl)
- pkgver = r43.eac7db0
+ pkgver = r117.3f74880
pkgrel = 1
url = https://github.com/gkdr/lurch
arch = i686
@@ -20,4 +18,3 @@ pkgbase = libpurple-lurch-git
sha256sums = SKIP
pkgname = libpurple-lurch-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 15ef479e4b85..7c5754a53912 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
+# Contributor: eskimod
# Maintainer: Sýlvan Heuser <sylvan.heuser@gmx.net>
pkgname=libpurple-lurch-git
_pkgname=lurch
-pkgver=r43.eac7db0
+pkgver=r117.3f74880
pkgrel=1
pkgdesc='Plugin for libpurple (Pidgin, Adium, etc) implementing OMEMO (using axolotl)'
arch=('i686' 'x86_64')
@@ -25,6 +26,9 @@ pkgver () {
prepare() {
cd "$srcdir/$_pkgname"
msg2 "Getting submodules"
+ # .gitmodules specifies relative paths that don't resolve correctly on a local clone
+ git config --file=.gitmodules submodule."lib/axc".url "https://github.com/gkdr/axc"
+ git config --file=.gitmodules submodule."lib/libomemo".url "https://github.com/gkdr/libomemo"
git submodule update --init --recursive
}