summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Beringer2016-05-28 20:11:09 +0200
committerIan Beringer2016-05-28 20:11:09 +0200
commit211648dae8c82935d14674f4eb8e5ea5758976ee (patch)
tree506f5f12be29471e2a31dee0e7815be9ff636551
downloadaur-211648dae8c82935d14674f4eb8e5ea5758976ee.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7241997ec9c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libqb-git
+ pkgdesc = Library with the primary purpose of providing high performance client server reusable features
+ pkgver = 1.0.19.g70340f7
+ pkgrel = 1
+ url = https://github.com/ClusterLabs/libqb-git/wiki
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = git
+ makedepends = doxygen
+ makedepends = splint
+ provides = libqb
+ conflicts = libqb
+ source = libqb::git+https://github.com/ClusterLabs/libqb.git
+ sha256sums = SKIP
+
+pkgname = libqb-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87f7ecd5eb70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+#Maintainer: Ian Beringer <ian@ianberinger.com>
+
+pkgname=libqb-git
+_pkgname=libqb
+pkgver=1.0.19.g70340f7
+pkgrel=1
+pkgdesc='Library with the primary purpose of providing high performance client server reusable features'
+arch=("i686" "x86_64")
+makedepends=("git" "doxygen" "splint")
+license=('LGPL2.1')
+url=https://github.com/ClusterLabs/$pkgname/wiki
+source=("${_pkgname}::git+https://github.com/ClusterLabs/libqb.git")
+sha256sums=('SKIP')
+provides=('libqb')
+conflicts=('libqb')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --tags | sed -e 's:v::' -e 's/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ ./autogen.sh
+ ./configure --prefix=/usr --sbindir=/usr/bin --libdir=/usr/lib
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make DESTDIR="$pkgdir/" install
+}