summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThermi2015-02-07 18:30:33 +0100
committerThermi2015-02-07 18:30:33 +0100
commitc2477d0f2f9bf897eabc93e00960b633eb6d5320 (patch)
tree7c85374abfd6813f1da6e58d38dfa8b57c1729d8
parent6c2c7e5212ee6105faf69f27ffdaac933369288e (diff)
downloadaur-c2477d0f2f9bf897eabc93e00960b633eb6d5320.tar.gz
libqcow: Added working PKGBUILD
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 22 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 185db25373ee..16853217ce6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = libqcow
pkgdesc = Library and tools to support QEMU copy-on-write image format (QCOW, QCOW2), including a FUSE-based mount utility
- pkgver = 20120522
+ pkgver = 20150105
pkgrel = 1
- url = http://code.google.com/p/libqcow/
+ url = https://github.com/libyal/libqcow/
arch = i686
arch = x86_64
license = LGPL3
+ makedepends = zlib
+ makedepends = openssl
+ makedepends = python
depends = fuse
depends = openssl
- source = http://libqcow.googlecode.com/files/libqcow-alpha-20120522.tar.gz
- md5sums = 159703e5c34736d4fc38a509c62de1b9
+ source = https://github.com/libyal/libqcow/archive/20150105.tar.gz
+ sha256sums = 1c93bb151506ecaf7a681a24444f2538f6541b700f4a29f39d536dc988895789
pkgname = libqcow
diff --git a/PKGBUILD b/PKGBUILD
index 65a3dc1650bb..4c90e9bb5431 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,25 @@
# Maintainer: David McIlwraith <archaios at archaios dot net>
pkgname=libqcow
-pkgver=20120522
+pkgver=20150105
pkgrel=1
pkgdesc="Library and tools to support QEMU copy-on-write image format (QCOW, QCOW2), including a FUSE-based mount utility"
-url="http://code.google.com/p/libqcow/"
+url="https://github.com/libyal/libqcow/"
arch=('i686' 'x86_64')
license=('LGPL3')
depends=('fuse' 'openssl')
-source=(http://libqcow.googlecode.com/files/$pkgname-alpha-$pkgver.tar.gz)
-md5sums=('159703e5c34736d4fc38a509c62de1b9')
+makedepends=('zlib' 'openssl' 'python')
+source=("https://github.com/libyal/libqcow/archive/$pkgver.tar.gz")
+sha256sums=('1c93bb151506ecaf7a681a24444f2538f6541b700f4a29f39d536dc988895789')
build(){
- cd $srcdir/$pkgname-$pkgver
- ./configure --prefix=/usr
- make
- make DESTDIR=$pkgdir install
+ cd $srcdir/$pkgname-$pkgver
+ ./synclibs.sh
+ ./autogen.sh
+ ./configure --prefix=/usr --enable-python --enable-verbose-output --enable-debug-output --enable-wide-character-type
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
}