summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladislav Suratov2017-04-12 02:31:02 +0300
committerVladislav Suratov2017-04-12 02:31:02 +0300
commit65c559a9fc54456e9861ebed5e85cc72495c7a05 (patch)
treeee8d78499fa6e9a267f7edc46370d902cb68c9bf
downloadaur-65c559a9fc54456e9861ebed5e85cc72495c7a05.tar.gz
Initial release of dark theme plugin libqdark.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..823c49295281
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libqdark-git
+ pkgdesc = Plugin for Qt applications. Choose the dark side of the style.
+ pkgver = 0.2.r0.ge6c4896
+ pkgrel = 1
+ url = http://github.com/suratovvlad/libqdark
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = qt5-tools
+ depends = qt5-base
+ source = libqdark::git+https://github.com/suratovvlad/libqdark.git
+ sha512sums = SKIP
+
+pkgname = libqdark-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48e599627b8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: degreeme <suratovvlad@gmail.com>
+
+pkgname=libqdark-git
+pkgver=0.2.r0.ge6c4896
+pkgrel=1
+pkgdesc="Plugin for Qt applications. Choose the dark side of the style."
+arch=('i686' 'x86_64')
+url="http://github.com/suratovvlad/libqdark"
+license=('MIT')
+depends=('qt5-base')
+makedepends=('qt5-tools')
+source=("${pkgname%-*}::git+https://github.com/suratovvlad/libqdark.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-*}
+ _tag=$(git tag -l --sort -v:refname | sed -n '1,1{s/release-//p}')
+ _rev=$(git rev-list --count release-${_tag}..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash"
+}
+
+
+build() {
+ cd ${pkgname%-*}
+ git submodule update --init
+ qmake-qt5 libqdark.pro
+ make
+}
+
+package() {
+ cd ${pkgname%-*}
+ make INSTALL_ROOT="$pkgdir" install
+} \ No newline at end of file