summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Strapp2016-02-17 23:14:21 +0000
committerPeter Strapp2016-02-17 23:14:21 +0000
commit3e9cff1f60325015904c7b10b5c0ec509a549c06 (patch)
treef4cd7fca0c78dbdd378196136e51f18ad61a5738
downloadaur-3e9cff1f60325015904c7b10b5c0ec509a549c06.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD39
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22bb4cf711c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 5.0.0
+# Wed Feb 17 22:51:59 UTC 2016
+pkgbase = libqhy-git
+ pkgver = 20150917
+ pkgrel = 1
+ url = https://github.com/qhyccd-lzr/QHYCCD_Linux
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = boost
+ depends = libusb
+ source = git+https://github.com/qhyccd-lzr/QHYCCD_Linux.git
+ sha1sums = SKIP
+
+pkgname = libqhy-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9a915805ee74
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+output
+pkg
+src
+*.tar.gz
+*.tar.xz
+QHYCCD_Linux
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e54be84a7350
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id$
+# Maintainer: Peter Strapp <peter at strapp.co.uk>
+
+pkgname=libqhy-git
+pkgver=20150917
+pkgrel=1
+url="https://github.com/qhyccd-lzr/QHYCCD_Linux"
+license=(GPL2)
+arch=(i686 x86_64)
+depends=(libusb)
+makedepends=(cmake boost)
+source=("git+https://github.com/qhyccd-lzr/QHYCCD_Linux.git")
+sha1sums=('SKIP')
+
+_gitname='QHYCCD_Linux'
+
+pkgver() {
+ cd "$_gitname"
+ git show -s --format="%ci" HEAD | sed -e 's/-//g' -e 's/ .*//'
+}
+
+prepare() {
+ mkdir -p build
+ cd "$_gitname"
+ sed -e 's|[“”]|"|g' -i CMakeLists.txt # Fix for bad character encoding
+ sed -e 's|"\/lib|"${CMAKE_INSTALL_PREFIX}/lib|g' -i CMakeLists.txt # Allow installing outside of /lib
+ sed -e 's|\} ${LIB_INSTALL_DIR}|} '"${pkgdir}"'${LIB_INSTALL_DIR}|g' -i CMakeLists.txt # Create symlinks inside the package
+}
+
+build() {
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ../${_gitname}
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+} \ No newline at end of file