summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Cornu2016-02-13 03:12:09 +0100
committerNicolas Cornu2016-02-13 03:12:09 +0100
commita84b86db8b2394ae0db5ab0170416858872d1abb (patch)
tree4dcdafa08af59e389061611348ce4b7af40253ef
parent740640c13bacc03a2015b77e71b10b096108a259 (diff)
downloadaur-a84b86db8b2394ae0db5ab0170416858872d1abb.tar.gz
Update to v2.5.0.176
-rw-r--r--.SRCINFO14
-rw-r--r--0001-Fix-ambiguous-use-of-relative-due-to-ADL-with-boost.patch29
-rw-r--r--0001-Use-std-is_same-instead-of-boost-s-one.patch63
-rw-r--r--PKGBUILD15
-rw-r--r--without_qiprobe.patch110
5 files changed, 110 insertions, 121 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f48b7a6b96ed..5ffb37a02050 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by makepkg 5.0.0
+# Sat Feb 13 02:11:21 UTC 2016
pkgbase = libqi
pkgdesc = Qi library from Aldebaran
- pkgver = 2.1.3
+ pkgver = 2.5.0.176
pkgrel = 1
url = https://github.com/aldebaran/libqi
arch = i686
@@ -10,10 +12,12 @@ pkgbase = libqi
depends = boost
options = strip
options = staticlibs
- source = https://github.com/aldebaran/libqi/archive/v2.1.3.tar.gz
- source = without_qiprobe.patch
- sha1sums = 778b4b82da7ca3c5522244e73fd901962a025271
- sha1sums = aedb17967843f9745d6ef9a2a2c183b669e94939
+ source = https://github.com/aldebaran/libqi/archive/v2.5.0.176.tar.gz
+ source = 0001-Fix-ambiguous-use-of-relative-due-to-ADL-with-boost.patch
+ source = 0001-Use-std-is_same-instead-of-boost-s-one.patch
+ sha1sums = 9a082e8cf814aa5f19d5b7d4c5b370aec583ea2c
+ sha1sums = 0bded2e9883ae1dc206001126d43f280050f82c9
+ sha1sums = 2be8ae48fd4b0275cddc8fc2d9685676d526a405
pkgname = libqi
diff --git a/0001-Fix-ambiguous-use-of-relative-due-to-ADL-with-boost.patch b/0001-Fix-ambiguous-use-of-relative-due-to-ADL-with-boost.patch
new file mode 100644
index 000000000000..a45909949f8b
--- /dev/null
+++ b/0001-Fix-ambiguous-use-of-relative-due-to-ADL-with-boost.patch
@@ -0,0 +1,29 @@
+From a3672cee0da8ad00dc54955be7c51c2c13a196e2 Mon Sep 17 00:00:00 2001
+From: Nicolas Cornu <ncornu@aldebaran.com>
+Date: Mon, 28 Dec 2015 14:16:39 +0100
+Subject: [PATCH] Fix ambiguous use of "relative()" due to ADL with boost
+
+Change-Id: Ib7beb4557621cd509b50d030bdc52dd53db8193a
+Reviewed-on: http://gerrit.aldebaran.lan/66725
+Reviewed-by: ncornu <ncornu@aldebaran.com>
+Tested-by: ncornu <ncornu@aldebaran.com>
+---
+ src/sdklayout-boost.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/sdklayout-boost.cpp b/src/sdklayout-boost.cpp
+index ba11d44..cd3f68e 100644
+--- a/src/sdklayout-boost.cpp
++++ b/src/sdklayout-boost.cpp
+@@ -539,7 +539,7 @@ namespace qi {
+ const std::string fullPath = itD->path().string(qi::unicodeFacet());
+ if (boost::regex_match(fullPath, pathRegex))
+ {
+- std::string relativePath = relative(dataPath, itD->path());
++ std::string relativePath = ::relative(dataPath, itD->path());
+ if (matchedPaths.find(relativePath) == matchedPaths.end())
+ {
+ // we only add the match if it was not found in a previous
+--
+2.7.1
+
diff --git a/0001-Use-std-is_same-instead-of-boost-s-one.patch b/0001-Use-std-is_same-instead-of-boost-s-one.patch
new file mode 100644
index 000000000000..5fb62a312994
--- /dev/null
+++ b/0001-Use-std-is_same-instead-of-boost-s-one.patch
@@ -0,0 +1,63 @@
+From 5901fd41964f33b868245dc1ed8e6bd74d825e4a Mon Sep 17 00:00:00 2001
+From: Nicolas Cornu <ncornu@aldebaran.com>
+Date: Mon, 28 Dec 2015 14:19:13 +0100
+Subject: [PATCH] Use std::is_same instead of boost's one
+
+Change-Id: Icf30a7afd89aafada9be9ed8c3cf65649fbca7f7
+Reviewed-on: http://gerrit.aldebaran.lan/66726
+Reviewed-by: ncornu <ncornu@aldebaran.com>
+Tested-by: ncornu <ncornu@aldebaran.com>
+---
+ qi/detail/executioncontext.hpp | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/qi/detail/executioncontext.hpp b/qi/detail/executioncontext.hpp
+index fa9a5f2..cba60f2 100644
+--- a/qi/detail/executioncontext.hpp
++++ b/qi/detail/executioncontext.hpp
+@@ -10,6 +10,7 @@
+ #include <boost/function.hpp>
+ #include <qi/clock.hpp>
+ #include <qi/api.hpp>
++#include <type_traits>
+
+ namespace qi
+ {
+@@ -53,14 +54,14 @@ public:
+ /// call a callback asynchronously to be executed in delay
+ /// @deprecated since 2.5
+ template <typename R>
+- QI_API_DEPRECATED typename boost::disable_if<boost::is_same<R, void>,
++ QI_API_DEPRECATED typename boost::disable_if<std::is_same<R, void>,
+ qi::Future<R> >::type
+ async(const boost::function<R()>& callback,
+ qi::Duration delay);
+ /// call a callback asynchronously to be executed on tp
+ /// @deprecated since 2.5
+ template <typename R>
+- QI_API_DEPRECATED typename boost::disable_if<boost::is_same<R, void>,
++ QI_API_DEPRECATED typename boost::disable_if<std::is_same<R, void>,
+ qi::Future<R> >::type
+ async(const boost::function<R()>& callback, qi::SteadyClockTimePoint tp);
+
+@@ -157,7 +158,7 @@ void checkCanceled(qi::Future<void> f, qi::Promise<R> p)
+ }
+
+ template <typename R>
+-typename boost::disable_if<boost::is_same<R, void>,
++typename boost::disable_if<std::is_same<R, void>,
+ qi::Future<R> >::type
+ ExecutionContext::async(const boost::function<R()>& callback,
+ qi::Duration delay)
+@@ -174,7 +175,7 @@ typename boost::disable_if<boost::is_same<R, void>,
+ }
+
+ template <typename R>
+-typename boost::disable_if<boost::is_same<R, void>,
++typename boost::disable_if<std::is_same<R, void>,
+ qi::Future<R> >::type
+ ExecutionContext::async(const boost::function<R()>& callback,
+ qi::SteadyClockTimePoint tp)
+--
+2.7.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 879c8b1833fb..a1b1b00e2776 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nicolas Cornu <ncornu@aldebaran.com>
pkgname=libqi
-pkgver=2.1.3
+pkgver=2.5.0.176
pkgrel=1
pkgdesc="Qi library from Aldebaran"
arch=('i686' 'x86_64')
@@ -11,21 +11,24 @@ depends=('boost')
options=('strip' 'staticlibs')
makedepends=('qibuild')
source=("${url}/archive/v${pkgver}.tar.gz"
- "without_qiprobe.patch")
+ "0001-Fix-ambiguous-use-of-relative-due-to-ADL-with-boost.patch"
+ "0001-Use-std-is_same-instead-of-boost-s-one.patch")
-sha1sums=('778b4b82da7ca3c5522244e73fd901962a025271'
- 'aedb17967843f9745d6ef9a2a2c183b669e94939')
+sha1sums=('9a082e8cf814aa5f19d5b7d4c5b370aec583ea2c'
+ '0bded2e9883ae1dc206001126d43f280050f82c9'
+ '2be8ae48fd4b0275cddc8fc2d9685676d526a405')
prepare() {
cd ${srcdir}/${pkgname}-${pkgver}
- patch -p1 -i "$srcdir/without_qiprobe.patch"
+ patch -p1 -i "$srcdir/0001-Fix-ambiguous-use-of-relative-due-to-ADL-with-boost.patch"
+ patch -p1 -i "$srcdir/0001-Use-std-is_same-instead-of-boost-s-one.patch"
}
build() {
cd ${srcdir}/${pkgname}-${pkgver}
mkdir -p BUILD && cd BUILD
- cmake .. -DQI_WITH_TESTS=OFF -DQI_DIR=../sdk/cmake -DWITH_PROBES=OFF -DCMAKE_INSTALL_PREFIX:PATH=/usr
+ cmake .. -DQI_WITH_TESTS=OFF -DQI_DIR=../sdk/cmake -DWITH_PROBES=OFF -DCMAKE_INSTALL_PREFIX:PATH=/usr -DCMAKE_BUILD_TYPE=Release
make
}
diff --git a/without_qiprobe.patch b/without_qiprobe.patch
deleted file mode 100644
index 1f59edee2030..000000000000
--- a/without_qiprobe.patch
+++ /dev/null
@@ -1,110 +0,0 @@
-Only in libqi-2.1.3: BUILD
-diff -puZ -r libqi-2.1.3old/CMakeLists.txt libqi-2.1.3/CMakeLists.txt
---- libqi-2.1.3old/CMakeLists.txt 2014-11-13 19:07:49.000000000 +0100
-+++ libqi-2.1.3/CMakeLists.txt 2015-03-26 17:40:29.294386931 +0100
-@@ -28,12 +28,17 @@ qi_add_optional_package(BOOST_LOCALE "En
- enable_testing()
- include(CMakeDependentOption)
-
--find_package(qiprobes)
--qiprobes_create_probe(tp_qi
-- src/tp_qi.in.h
-- PROVIDER_NAME qi_qi)
--qiprobes_instrument_files(tp_qi
-- src/eventloop.cpp)
-+if (WITH_PROBES)
-+ find_package(qiprobes)
-+ qiprobes_create_probe(tp_qi
-+ src/tp_qi.in.h
-+ PROVIDER_NAME qi_qi)
-+ qiprobes_instrument_files(tp_qi
-+ src/eventloop.cpp)
-+ set(_tp_qi "tp_qi")
-+else()
-+ set(_tp_qi "")
-+endif()
-
- set(H
- qi/details/eventloop.hxx
-@@ -157,7 +162,7 @@ list(APPEND C ${_out})
- include_directories("${CMAKE_CURRENT_SOURCE_DIR}")
- include_directories("${CMAKE_CURRENT_SOURCE_DIR}/external")
-
--qi_create_lib(qi ${_libtype} ${H} ${C} SUBMODULE tp_qi)
-+qi_create_lib(qi ${_libtype} ${H} ${C} SUBMODULE ${_tp_qi})
-
- if (WITH_QT_QTCORE)
- qi_use_lib(qi QT_QTCORE)
-Only in libqi-2.1.3/examples/qitranslate/po: share
-diff -puZ -r libqi-2.1.3old/src/eventloop.cpp libqi-2.1.3/src/eventloop.cpp
---- libqi-2.1.3old/src/eventloop.cpp 2014-11-13 19:07:49.000000000 +0100
-+++ libqi-2.1.3/src/eventloop.cpp 2015-03-26 17:40:29.294386931 +0100
-@@ -16,7 +16,11 @@
- #include <qi/future.hpp>
-
- #include "eventloop_p.hpp"
--#include "tp_qi.h"
-+#ifdef WITH_PROBES
-+# include "tp_qi.h"
-+#else
-+# define tracepoint(...)
-+#endif
-
- qiLogCategory("qi.eventloop");
-
-diff -puZ -r libqi-2.1.3old/tests/CMakeLists.txt libqi-2.1.3/tests/CMakeLists.txt
---- libqi-2.1.3old/tests/CMakeLists.txt 2014-11-13 19:07:49.000000000 +0100
-+++ libqi-2.1.3/tests/CMakeLists.txt 2015-03-26 18:13:47.511017563 +0100
-@@ -1,29 +1,31 @@
- ## Copyright (c) 2012 Aldebaran Robotics. All rights reserved.
- ## Use of this source code is governed by a BSD-style license that can be
- ## found in the COPYING file.
--if(${QIBUILD_VERSION} VERSION_GREATER "3.1")
-- qi_create_test_helper(testlaunch testlaunch.cpp)
-- qi_create_test_helper(testlaunchloop testlaunchloop.cpp)
-- qi_create_test_helper(check_env check_env.cpp)
-- qi_create_test_helper(check_machineid check_machineid.cpp)
-- qi_create_test_helper(test_application test_application.cpp)
--else()
-- qi_create_bin(testlaunch NO_INSTALL testlaunch.cpp)
-- qi_create_bin(testlaunchloop NO_INSTALL testlaunchloop.cpp)
-- qi_create_bin(check_env NO_INSTALL check_env.cpp)
-- qi_create_bin(check_machineid NO_INSTALL check_machineid.cpp)
-- qi_create_bin(test_application NO_INSTALL test_application.cpp)
--endif()
-+if(QI_WITH_TESTS)
-+ if(${QIBUILD_VERSION} VERSION_GREATER "3.1")
-+ qi_create_test_helper(testlaunch testlaunch.cpp)
-+ qi_create_test_helper(testlaunchloop testlaunchloop.cpp)
-+ qi_create_test_helper(check_env check_env.cpp)
-+ qi_create_test_helper(check_machineid check_machineid.cpp)
-+ qi_create_test_helper(test_application test_application.cpp)
-+ else()
-+ qi_create_bin(testlaunch NO_INSTALL testlaunch.cpp)
-+ qi_create_bin(testlaunchloop NO_INSTALL testlaunchloop.cpp)
-+ qi_create_bin(check_env NO_INSTALL check_env.cpp)
-+ qi_create_bin(check_machineid NO_INSTALL check_machineid.cpp)
-+ qi_create_bin(test_application NO_INSTALL test_application.cpp)
-+ endif()
-
--qi_use_lib(testlaunchloop QI)
--qi_use_lib(check_env QI)
--qi_use_lib(check_machineid QI)
--qi_use_lib(test_application QI)
-+ qi_use_lib(testlaunchloop QI)
-+ qi_use_lib(check_env QI)
-+ qi_use_lib(check_machineid QI)
-+ qi_use_lib(test_application QI)
-
--set_target_properties(testlaunch PROPERTIES FOLDER tests)
--set_target_properties(testlaunchloop PROPERTIES FOLDER tests)
--set_target_properties(check_env PROPERTIES FOLDER tests)
--set_target_properties(test_application PROPERTIES FOLDER tests)
-+ set_target_properties(testlaunch PROPERTIES FOLDER tests)
-+ set_target_properties(testlaunchloop PROPERTIES FOLDER tests)
-+ set_target_properties(check_env PROPERTIES FOLDER tests)
-+ set_target_properties(test_application PROPERTIES FOLDER tests)
-+endif()
-
- qi_create_gtest(test_qiclock SRC test_qiclock.cpp DEPENDS QI GTEST)
- qi_create_gtest(test_qipath SRC test_qipath.cpp ../src/utils.cpp DEPENDS QI GTEST)