summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Spies2015-09-10 11:53:12 -0230
committerLukas Spies2015-09-10 11:53:12 -0230
commit88d0830280b12d3d4cf041d0e5d6a56146125a9a (patch)
treef61b5646c7585fb7cc0abf01406dd57c9bebbf27
downloadaur-88d0830280b12d3d4cf041d0e5d6a56146125a9a.tar.gz
Re-Upload to new AUR
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca31f8482a88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libqpsd-git
+ pkgdesc = PSD & PSB Plugin for Qt/C++ (Qt4/Qt5)
+ pkgver = 20140927
+ pkgrel = 1
+ url = https://github.com/Code-ReaQtor/libqpsd
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = qt5-base
+ source = git://github.com/Code-ReaQtor/libqpsd
+ sha256sums = SKIP
+
+pkgname = libqpsd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..233d644d8a61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Lukas Spies <lukas_dot_spies_at_web_dot_de>
+
+_pkgname=libqpsd
+pkgname=libqpsd-git
+pkgver=20140927
+pkgrel=1
+pkgdesc="PSD & PSB Plugin for Qt/C++ (Qt4/Qt5) "
+arch=("i686" "x86_64")
+url="https://github.com/Code-ReaQtor/libqpsd"
+license=("LGPL")
+depends=("qt5-base")
+# depends=("qt4") # use this depends instead the above for Qt4 build
+makedepends=("git")
+source=("git://github.com/Code-ReaQtor/libqpsd")
+sha256sums=("SKIP")
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ sed -i "s|\$\$\[QT_INSTALL_PLUGINS\]|$pkgdir/usr/lib/qt/plugins|" QPsdPlugin.pro
+
+ mkdir -p build
+ cd build
+ qmake ..
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ cd build
+ make INSTALL_ROOT="$pkgdir" install
+}